diff mbox series

[V5] package/c-periphery: bump version to 2.2.1

Message ID 20200601074841.6325-1-offougajoris@gmail.com
State Accepted
Headers show
Series [V5] package/c-periphery: bump version to 2.2.1 | expand

Commit Message

Joris OFFOUGA June 1, 2020, 7:48 a.m. UTC
Since commit "cmake: add cmake build support"
(https://github.com/vsergeev/c-periphery/commit/952e1e906a5d65b78932128af24b7dbb8cce2e9dvsergeev/c-periphery@d0a973c),
c-periphery implement cmake build, so use cmake-package instead of generic-package

The hash of the license file is updated due to an update in the
copyright year:

  - Copyright (c) 2014-2019 vsergeev / Ivan (Vanya) A. Sergeev
  + Copyright (c) 2014-2020 vsergeev / Ivan (Vanya) A. Sergeev

Signed-off-by: Joris Offouga <offougajoris@gmail.com>
---
  changes v4-v5:
    - add missing changelog
  changes v3-v4
    - update package to 2.2.1, this version integrate _XOPEN_SOURCE feature
  change v2->v3
    - fix commit log
    - use _XOPEN_SOURCE instead of __USE_XOPEN according to man poll. Suggested-by Thomas Petazzoni
    - Install library to $(TARGET_DIR)
  change v1->v2:
    - fix correct copyright year 2020

 package/c-periphery/c-periphery.hash |  4 ++--
 package/c-periphery/c-periphery.mk   | 19 +++----------------
 2 files changed, 5 insertions(+), 18 deletions(-)

Comments

Thomas Petazzoni June 2, 2020, 9:20 p.m. UTC | #1
On Mon,  1 Jun 2020 09:48:40 +0200
Joris Offouga <offougajoris@gmail.com> wrote:

> Since commit "cmake: add cmake build support"
> (https://github.com/vsergeev/c-periphery/commit/952e1e906a5d65b78932128af24b7dbb8cce2e9dvsergeev/c-periphery@d0a973c),
> c-periphery implement cmake build, so use cmake-package instead of generic-package

You should have also explained that it now builds a shared library and
therefore INSTALL_TARGET = NO is no longer appropriate. I fixed that.

> +C_PERIPHERY_INSTALL_TARGET = YES

This raises a check-package warning, because this is the default value.
So I simply dropped this line when applying.

Applied to master. Thanks!

Thomas
diff mbox series

Patch

diff --git a/package/c-periphery/c-periphery.hash b/package/c-periphery/c-periphery.hash
index 244f8f60f1..a1842612b9 100644
--- a/package/c-periphery/c-periphery.hash
+++ b/package/c-periphery/c-periphery.hash
@@ -1,3 +1,3 @@ 
 # Locally calculated
-sha256 1c455c42b26818d199ac227cd19714f265623e15d363fdfdf47a2416a4165654  c-periphery-2.1.0.tar.gz
-sha256 e7b9464cb8511f19ddb40f9cf52fe86b3dfe38b2faed9d7bbc3d5707677ffbe3  LICENSE
+sha256 7afa2a18e0bf0ccb09b832017c61a411a94cff648a9a57f9f9068bcf14a5d972  c-periphery-2.2.1.tar.gz
+sha256 7121a0a2ba36ed9388be2f1a916f0e3584d8e49cc7888fbcfcf83bab2a8bebef  LICENSE
diff --git a/package/c-periphery/c-periphery.mk b/package/c-periphery/c-periphery.mk
index bb50434efa..6687dced6f 100644
--- a/package/c-periphery/c-periphery.mk
+++ b/package/c-periphery/c-periphery.mk
@@ -4,24 +4,11 @@ 
 #
 ################################################################################
 
-C_PERIPHERY_VERSION = 2.1.0
+C_PERIPHERY_VERSION = 2.2.1
 C_PERIPHERY_SITE = $(call github,vsergeev,c-periphery,v$(C_PERIPHERY_VERSION))
 C_PERIPHERY_INSTALL_STAGING = YES
-# only a static library
-C_PERIPHERY_INSTALL_TARGET = NO
+C_PERIPHERY_INSTALL_TARGET = YES
 C_PERIPHERY_LICENSE = MIT
 C_PERIPHERY_LICENSE_FILES = LICENSE
 
-define C_PERIPHERY_BUILD_CMDS
-	$(TARGET_MAKE_ENV) $(TARGET_CONFIGURE_OPTS) $(MAKE) -C $(@D)
-endef
-
-# There is no 'install' rule in the Makefile, so we handle things
-# manually.
-define C_PERIPHERY_INSTALL_STAGING_CMDS
-	$(INSTALL) -D -m 0644 $(@D)/periphery.a $(STAGING_DIR)/usr/lib/libc-periphery.a
-	mkdir -p $(STAGING_DIR)/usr/include/c-periphery/
-	cp -dpfr $(@D)/src/*.h $(STAGING_DIR)/usr/include/c-periphery/
-endef
-
-$(eval $(generic-package))
+$(eval $(cmake-package))