diff mbox series

package/cegui: disable minizip support

Message ID 20200407151516.120770-1-b.bilas@grinn-global.com
State Accepted
Headers show
Series package/cegui: disable minizip support | expand

Commit Message

Bartosz Bilas April 7, 2020, 3:15 p.m. UTC
Disable support for minizip since cegui is not compatible
with the existing buildroot's version due to lack of
necessary header. It will be restored when upstream will
switch to the new version.

Fixes:
 - http://autobuild.buildroot.net/results/65fa719e8b2466409a12eb103a8938e1488efc0c
 - http://autobuild.buildroot.net/results/ef37a0cc16daacb7206d736c86b511c7d90eefe0

and many more.

Signed-off-by: Bartosz Bilas <b.bilas@grinn-global.com>
---
 package/cegui/cegui.mk | 10 ++--------
 1 file changed, 2 insertions(+), 8 deletions(-)

Comments

Thomas Petazzoni April 8, 2020, 7:47 p.m. UTC | #1
On Tue,  7 Apr 2020 17:15:16 +0200
Bartosz Bilas <b.bilas@grinn-global.com> wrote:

> Disable support for minizip since cegui is not compatible
> with the existing buildroot's version due to lack of
> necessary header. It will be restored when upstream will
> switch to the new version.
> 
> Fixes:
>  - http://autobuild.buildroot.net/results/65fa719e8b2466409a12eb103a8938e1488efc0c
>  - http://autobuild.buildroot.net/results/ef37a0cc16daacb7206d736c86b511c7d90eefe0
> 
> and many more.
> 
> Signed-off-by: Bartosz Bilas <b.bilas@grinn-global.com>
> ---
>  package/cegui/cegui.mk | 10 ++--------
>  1 file changed, 2 insertions(+), 8 deletions(-)

Applied to master, thanks.

Thomas
diff mbox series

Patch

diff --git a/package/cegui/cegui.mk b/package/cegui/cegui.mk
index 134b222362..434201b1f8 100644
--- a/package/cegui/cegui.mk
+++ b/package/cegui/cegui.mk
@@ -9,7 +9,8 @@  CEGUI_SITE = $(call github,cegui,cegui,v$(CEGUI_VERSION))
 CEGUI_LICENSE = MIT
 CEGUI_LICENSE_FILES = COPYING
 CEGUI_INSTALL_STAGING = YES
-CEGUI_CONF_OPTS += -DCEGUI_BUILD_XMLPARSER_XERCES=OFF
+CEGUI_CONF_OPTS += -DCEGUI_BUILD_XMLPARSER_XERCES=OFF \
+		   -DCEGUI_HAS_MINIZIP_RESOURCE_PROVIDER=OFF
 CEGUI_DEPENDENCIES = glm \
 		$(if $(BR2_PACKAGE_LIBGLFW),libglfw) \
 		$(if $(BR2_PACKAGE_HAS_LIBGL),libgl) \
@@ -66,13 +67,6 @@  else
 CEGUI_CONF_OPTS += -DCEGUI_HAS_FREETYPE=OFF
 endif
 
-ifeq ($(BR2_PACKAGE_MINIZIP),y)
-CEGUI_DEPENDENCIES += minizip
-CEGUI_CONF_OPTS += -DCEGUI_HAS_MINIZIP_RESOURCE_PROVIDER=ON
-else
-CEGUI_CONF_OPTS += -DCEGUI_HAS_MINIZIP_RESOURCE_PROVIDER=OFF
-endif
-
 ifeq ($(BR2_PACKAGE_LIBXML2),y)
 CEGUI_DEPENDENCIES += libxml2
 CEGUI_CONF_OPTS += -DCEGUI_BUILD_XMLPARSER_LIBXML2=ON