diff mbox series

[1/1] linux-tools: perf: Add dependencies for binutils and openssl

Message ID 20200302224934.1356690-1-hancock@sedsystems.ca
State Accepted
Headers show
Series [1/1] linux-tools: perf: Add dependencies for binutils and openssl | expand

Commit Message

Robert Hancock March 2, 2020, 10:49 p.m. UTC
perf auto-detects and uses the libbfd (from binutils) and openssl
libraries if they are detected and happen to be built before perf is,
but if they're not, or if per-package directories are enabled, it won't
detect these libraries. Explicitly add dependencies on these packages if
they are enabled, and disable the feature if not, so that the behavior
is deterministic.

Signed-off-by: Robert Hancock <hancock@sedsystems.ca>
---
 package/linux-tools/linux-tool-perf.mk.in | 12 ++++++++++++
 1 file changed, 12 insertions(+)

Comments

Yann E. MORIN March 19, 2020, 5:28 p.m. UTC | #1
Robert, All,

On 2020-03-02 16:49 -0600, Robert Hancock spake thusly:
> perf auto-detects and uses the libbfd (from binutils) and openssl
> libraries if they are detected and happen to be built before perf is,
> but if they're not, or if per-package directories are enabled, it won't
> detect these libraries. Explicitly add dependencies on these packages if
> they are enabled, and disable the feature if not, so that the behavior
> is deterministic.
> 
> Signed-off-by: Robert Hancock <hancock@sedsystems.ca>

Applied to master, thanks.

Regards,
Yann E. MORIN.

> ---
>  package/linux-tools/linux-tool-perf.mk.in | 12 ++++++++++++
>  1 file changed, 12 insertions(+)
> 
> diff --git a/package/linux-tools/linux-tool-perf.mk.in b/package/linux-tools/linux-tool-perf.mk.in
> index 80e00c3c56..7106b622cb 100644
> --- a/package/linux-tools/linux-tool-perf.mk.in
> +++ b/package/linux-tools/linux-tool-perf.mk.in
> @@ -82,6 +82,18 @@ else
>  PERF_MAKE_FLAGS += NO_LIBELF=1 NO_DWARF=1
>  endif
>  
> +ifeq ($(BR2_PACKAGE_BINUTILS),y)
> +PERF_DEPENDENCIES += binutils
> +else
> +PERF_MAKE_FLAGS += NO_DEMANGLE=1
> +endif
> +
> +ifeq ($(BR2_PACKAGE_OPENSSL),y)
> +PERF_DEPENDENCIES += openssl
> +else
> +PERF_MAKE_FLAGS += NO_LIBCRYPTO=1
> +endif
> +
>  ifeq ($(BR2_PACKAGE_ZLIB),y)
>  PERF_DEPENDENCIES += zlib
>  else
> -- 
> 2.24.1
>
Peter Korsgaard March 27, 2020, 10:33 p.m. UTC | #2
>>>>> "Robert" == Robert Hancock <hancock@sedsystems.ca> writes:

 > perf auto-detects and uses the libbfd (from binutils) and openssl
 > libraries if they are detected and happen to be built before perf is,
 > but if they're not, or if per-package directories are enabled, it won't
 > detect these libraries. Explicitly add dependencies on these packages if
 > they are enabled, and disable the feature if not, so that the behavior
 > is deterministic.

 > Signed-off-by: Robert Hancock <hancock@sedsystems.ca>

Committed to 2019.02.x, 2019.11.x and 2020.02.x, thanks.
diff mbox series

Patch

diff --git a/package/linux-tools/linux-tool-perf.mk.in b/package/linux-tools/linux-tool-perf.mk.in
index 80e00c3c56..7106b622cb 100644
--- a/package/linux-tools/linux-tool-perf.mk.in
+++ b/package/linux-tools/linux-tool-perf.mk.in
@@ -82,6 +82,18 @@  else
 PERF_MAKE_FLAGS += NO_LIBELF=1 NO_DWARF=1
 endif
 
+ifeq ($(BR2_PACKAGE_BINUTILS),y)
+PERF_DEPENDENCIES += binutils
+else
+PERF_MAKE_FLAGS += NO_DEMANGLE=1
+endif
+
+ifeq ($(BR2_PACKAGE_OPENSSL),y)
+PERF_DEPENDENCIES += openssl
+else
+PERF_MAKE_FLAGS += NO_LIBCRYPTO=1
+endif
+
 ifeq ($(BR2_PACKAGE_ZLIB),y)
 PERF_DEPENDENCIES += zlib
 else