diff mbox series

package/bluez-alsa: fix location of alsa config files

Message ID 20200201105640.8428-1-joerg.krause@embedded.rocks
State Accepted
Headers show
Series package/bluez-alsa: fix location of alsa config files | expand

Commit Message

Jörg Krause Feb. 1, 2020, 10:56 a.m. UTC
Since alsa-lib version 1.1.7 [1] the location for add-on config files
has changed.

In fact, the path for the alsa add-on config files has never been
correct set in the package (it should have been
`/usr/share/alsa/alsa.conf.d`).

With alsa-lib version 1.1.7 or later the correct path is
`/etc/alsa/conf.d`.

[1] https://github.com/alsa-project/alsa-lib/commit/93e03bdc2a3dcd5d12516f5de78e14d88a32ff2c

Signed-off-by: Jörg Krause <joerg.krause@embedded.rocks>
---
 package/bluez-alsa/bluez-alsa.mk | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comments

Peter Korsgaard Feb. 4, 2020, 9:49 p.m. UTC | #1
>>>>> "Jörg" == Jörg Krause <joerg.krause@embedded.rocks> writes:

 > Since alsa-lib version 1.1.7 [1] the location for add-on config files
 > has changed.

 > In fact, the path for the alsa add-on config files has never been
 > correct set in the package (it should have been
 > `/usr/share/alsa/alsa.conf.d`).

 > With alsa-lib version 1.1.7 or later the correct path is
 > `/etc/alsa/conf.d`.

 > [1] https://github.com/alsa-project/alsa-lib/commit/93e03bdc2a3dcd5d12516f5de78e14d88a32ff2c

 > Signed-off-by: Jörg Krause <joerg.krause@embedded.rocks>

Committed, thanks.
Peter Korsgaard March 10, 2020, 8:50 p.m. UTC | #2
>>>>> "Jörg" == Jörg Krause <joerg.krause@embedded.rocks> writes:

 > Since alsa-lib version 1.1.7 [1] the location for add-on config files
 > has changed.

 > In fact, the path for the alsa add-on config files has never been
 > correct set in the package (it should have been
 > `/usr/share/alsa/alsa.conf.d`).

 > With alsa-lib version 1.1.7 or later the correct path is
 > `/etc/alsa/conf.d`.

 > [1] https://github.com/alsa-project/alsa-lib/commit/93e03bdc2a3dcd5d12516f5de78e14d88a32ff2c

 > Signed-off-by: Jörg Krause <joerg.krause@embedded.rocks>

Committed to 2019.11.x, thanks.
diff mbox series

Patch

diff --git a/package/bluez-alsa/bluez-alsa.mk b/package/bluez-alsa/bluez-alsa.mk
index c5a51ce5d4..7fed922a71 100644
--- a/package/bluez-alsa/bluez-alsa.mk
+++ b/package/bluez-alsa/bluez-alsa.mk
@@ -23,7 +23,7 @@  BLUEZ_ALSA_CONF_OPTS = \
 	--enable-aplay \
 	--disable-debug-time \
 	--with-alsaplugindir=/usr/lib/alsa-lib \
-	--with-alsaconfdir=/usr/share/alsa
+	--with-alsaconfdir=/etc/alsa/conf.d
 
 ifeq ($(BR2_PACKAGE_FDK_AAC),y)
 BLUEZ_ALSA_DEPENDENCIES += fdk-aac