diff mbox series

package/dhcp: install shared libraries

Message ID 20190809022759.8601-1-unixmania@gmail.com
State Accepted
Headers show
Series package/dhcp: install shared libraries | expand

Commit Message

Carlos Santos Aug. 9, 2019, 2:27 a.m. UTC
From: Carlos Santos <unixmania@gmail.com>

We don't use "make install" for target installation because we build all
utilities (server, relay, client) but install only the selected ones.

The utilities, however, require the shared libraries to work, so use the
"install-exec" make target to install them. This also installs static
libraries but they are removed later by target-finalize.

With this change the omshell utility is installed if server is selected.
We keep it, since it is small and may be useful at run-time.

Fixes:
  https://bugs.busybox.net/show_bug.cgi?id=12086

Signed-off-by: Carlos Santos <unixmania@gmail.com>
---
 package/dhcp/dhcp.mk | 10 ++++++++++
 1 file changed, 10 insertions(+)

Comments

Thomas Petazzoni Aug. 9, 2019, 8:55 p.m. UTC | #1
On Thu,  8 Aug 2019 23:27:59 -0300
unixmania@gmail.com wrote:

> From: Carlos Santos <unixmania@gmail.com>
> 
> We don't use "make install" for target installation because we build all
> utilities (server, relay, client) but install only the selected ones.
> 
> The utilities, however, require the shared libraries to work, so use the
> "install-exec" make target to install them. This also installs static
> libraries but they are removed later by target-finalize.
> 
> With this change the omshell utility is installed if server is selected.
> We keep it, since it is small and may be useful at run-time.
> 
> Fixes:
>   https://bugs.busybox.net/show_bug.cgi?id=12086
> 
> Signed-off-by: Carlos Santos <unixmania@gmail.com>
> ---
>  package/dhcp/dhcp.mk | 10 ++++++++++
>  1 file changed, 10 insertions(+)

Applied to master, thanks.

Thomas
Peter Korsgaard Sept. 2, 2019, 11:42 a.m. UTC | #2
>>>>> "unixmania" == unixmania  <unixmania@gmail.com> writes:

 > From: Carlos Santos <unixmania@gmail.com>
 > We don't use "make install" for target installation because we build all
 > utilities (server, relay, client) but install only the selected ones.

 > The utilities, however, require the shared libraries to work, so use the
 > "install-exec" make target to install them. This also installs static
 > libraries but they are removed later by target-finalize.

 > With this change the omshell utility is installed if server is selected.
 > We keep it, since it is small and may be useful at run-time.

 > Fixes:
 >   https://bugs.busybox.net/show_bug.cgi?id=12086

 > Signed-off-by: Carlos Santos <unixmania@gmail.com>

Committed to 2019.05.x, thanks.
diff mbox series

Patch

diff --git a/package/dhcp/dhcp.mk b/package/dhcp/dhcp.mk
index 86f5c69a77..5f56c86414 100644
--- a/package/dhcp/dhcp.mk
+++ b/package/dhcp/dhcp.mk
@@ -40,7 +40,15 @@  ifeq ($(BR2_PACKAGE_DHCP_SERVER_DELAYED_ACK),y)
 DHCP_CONF_OPTS += --enable-delayed-ack
 endif
 
+define DHCP_INSTALL_LIBS
+	$(MAKE) -C $(@D)/common install-exec DESTDIR=$(TARGET_DIR)
+	$(MAKE) -C $(@D)/omapip install-exec DESTDIR=$(TARGET_DIR)
+endef
+
 ifeq ($(BR2_PACKAGE_DHCP_SERVER),y)
+define DHCP_INSTALL_CTL_LIBS
+	$(MAKE) -C $(@D)/dhcpctl install-exec DESTDIR=$(TARGET_DIR)
+endef
 define DHCP_INSTALL_SERVER
 	mkdir -p $(TARGET_DIR)/var/lib
 	(cd $(TARGET_DIR)/var/lib; ln -snf /tmp dhcp)
@@ -99,6 +107,8 @@  endef
 endif
 
 define DHCP_INSTALL_TARGET_CMDS
+	$(DHCP_INSTALL_LIBS)
+	$(DHCP_INSTALL_CTL_LIBS)
 	$(DHCP_INSTALL_RELAY)
 	$(DHCP_INSTALL_SERVER)
 	$(DHCP_INSTALL_CLIENT)