diff mbox series

[v7,3/5] package/llvm: disable libxml2

Message ID 20190501194032.765-4-matthew.weber@rockwellcollins.com
State Accepted
Headers show
Series Compiler-rt Security Fuzzing Support | expand

Commit Message

Matt Weber May 1, 2019, 7:40 p.m. UTC
libxml2 is needed during Windows builds to populate the COFF
file manifest info.  This isn't required for Linux builds.

Cc: Romain Naour <romain.naour@gmail.com>
Signed-off-by: Matthew Weber <matthew.weber@rockwellcollins.com>
--
This change was discovered during testing of compiler-rt
patchset.  This patch could be independently applied.

v4
 - New patch

v5
 - Rebased post 2018.11 on master

v6
 - Updated comment about dependencies (Romain)
---
 package/llvm/llvm.mk | 5 +++++
 1 file changed, 5 insertions(+)

Comments

Arnout Vandecappelle Aug. 1, 2019, 4:43 p.m. UTC | #1
On 01/05/2019 21:40, Matt Weber wrote:
> libxml2 is needed during Windows builds to populate the COFF
> file manifest info.  This isn't required for Linux builds.
> 
> Cc: Romain Naour <romain.naour@gmail.com>
> Signed-off-by: Matthew Weber <matthew.weber@rockwellcollins.com>

 Applied to master, thanks.

 Regards,
 Arnout

> --
> This change was discovered during testing of compiler-rt
> patchset.  This patch could be independently applied.
> 
> v4
>  - New patch
> 
> v5
>  - Rebased post 2018.11 on master
> 
> v6
>  - Updated comment about dependencies (Romain)
> ---
>  package/llvm/llvm.mk | 5 +++++
>  1 file changed, 5 insertions(+)
> 
> diff --git a/package/llvm/llvm.mk b/package/llvm/llvm.mk
> index a1c0167ff6..9d276c5190 100644
> --- a/package/llvm/llvm.mk
> +++ b/package/llvm/llvm.mk
> @@ -133,6 +133,11 @@ HOST_LLVM_CONF_OPTS += -DLLVM_ENABLE_ZLIB=ON
>  HOST_LLVM_DEPENDENCIES += host-zlib
>  LLVM_CONF_OPTS += -DLLVM_ENABLE_ZLIB=OFF
>  
> +# libxml2 can be disabled as it is used for LLVM Windows builds where COFF
> +# files include manifest info
> +HOST_LLVM_CONF_OPTS += -DLLVM_ENABLE_LIBXML2=OFF
> +LLVM_CONF_OPTS += -DLLVM_ENABLE_LIBXML2=OFF
> +
>  # We don't use llvm for static only build, so enable PIC
>  HOST_LLVM_CONF_OPTS += -DLLVM_ENABLE_PIC=ON
>  LLVM_CONF_OPTS += -DLLVM_ENABLE_PIC=ON
>
diff mbox series

Patch

diff --git a/package/llvm/llvm.mk b/package/llvm/llvm.mk
index a1c0167ff6..9d276c5190 100644
--- a/package/llvm/llvm.mk
+++ b/package/llvm/llvm.mk
@@ -133,6 +133,11 @@  HOST_LLVM_CONF_OPTS += -DLLVM_ENABLE_ZLIB=ON
 HOST_LLVM_DEPENDENCIES += host-zlib
 LLVM_CONF_OPTS += -DLLVM_ENABLE_ZLIB=OFF
 
+# libxml2 can be disabled as it is used for LLVM Windows builds where COFF
+# files include manifest info
+HOST_LLVM_CONF_OPTS += -DLLVM_ENABLE_LIBXML2=OFF
+LLVM_CONF_OPTS += -DLLVM_ENABLE_LIBXML2=OFF
+
 # We don't use llvm for static only build, so enable PIC
 HOST_LLVM_CONF_OPTS += -DLLVM_ENABLE_PIC=ON
 LLVM_CONF_OPTS += -DLLVM_ENABLE_PIC=ON