diff mbox series

[1/1] package/valgrind: do not install header files on the target

Message ID 20190412164856.28641-1-titouan.christophe@railnova.eu
State Rejected
Headers show
Series [1/1] package/valgrind: do not install header files on the target | expand

Commit Message

Titouan Christophe April 12, 2019, 4:48 p.m. UTC
Signed-off-by: Titouan Christophe <titouan.christophe@railnova.eu>
---
 package/valgrind/valgrind.mk | 6 ++++++
 1 file changed, 6 insertions(+)

Comments

Arnout Vandecappelle April 12, 2019, 9:12 p.m. UTC | #1
On 12/04/2019 18:48, Titouan Christophe wrote:
> Signed-off-by: Titouan Christophe <titouan.christophe@railnova.eu>
> ---
>  package/valgrind/valgrind.mk | 6 ++++++
>  1 file changed, 6 insertions(+)
> 
> diff --git a/package/valgrind/valgrind.mk b/package/valgrind/valgrind.mk
> index cae14f79b9..8ee8c4585c 100644
> --- a/package/valgrind/valgrind.mk
> +++ b/package/valgrind/valgrind.mk
> @@ -64,6 +64,12 @@ endef
>  
>  VALGRIND_POST_INSTALL_TARGET_HOOKS += VALGRIND_INSTALL_UCLIBC_SUPP
>  
> +define VALGRIND_REMOVE_TARGET_HEADERS
> +	rm -rf $(TARGET_DIR)/usr/include/valgrind

 Why? target-finalize already does rm -rf $(TARGET_DIR)/usr/include.

 Assuming this was a mistake, I've marked this patch as Rejected in patchwork.
If there is a good reason to do this, please explain in the commit message and
resend.

 Regards,
 Arnout

> +endef
> +
> +VALGRIND_POST_INSTALL_TARGET_HOOKS += VALGRIND_REMOVE_TARGET_HEADERS
> +
>  ifeq ($(BR2_PACKAGE_VALGRIND_MEMCHECK),)
>  define VALGRIND_REMOVE_MEMCHECK
>  	rm -f $(TARGET_DIR)/usr/lib/valgrind/*memcheck*
>
Titouan Christophe April 13, 2019, 12:37 a.m. UTC | #2
Indeed, I did obtain /usr/include/valgrind/* after running `make 
valgrind` alone. Sorry for the spam.

Titouan

On 4/12/19 11:12 PM, Arnout Vandecappelle wrote:
> 
> 
> On 12/04/2019 18:48, Titouan Christophe wrote:
>> Signed-off-by: Titouan Christophe <titouan.christophe@railnova.eu>
>> ---
>>   package/valgrind/valgrind.mk | 6 ++++++
>>   1 file changed, 6 insertions(+)
>>
>> diff --git a/package/valgrind/valgrind.mk b/package/valgrind/valgrind.mk
>> index cae14f79b9..8ee8c4585c 100644
>> --- a/package/valgrind/valgrind.mk
>> +++ b/package/valgrind/valgrind.mk
>> @@ -64,6 +64,12 @@ endef
>>   
>>   VALGRIND_POST_INSTALL_TARGET_HOOKS += VALGRIND_INSTALL_UCLIBC_SUPP
>>   
>> +define VALGRIND_REMOVE_TARGET_HEADERS
>> +	rm -rf $(TARGET_DIR)/usr/include/valgrind
> 
>   Why? target-finalize already does rm -rf $(TARGET_DIR)/usr/include.
> 
>   Assuming this was a mistake, I've marked this patch as Rejected in patchwork.
> If there is a good reason to do this, please explain in the commit message and
> resend.
> 
>   Regards,
>   Arnout
> 
>> +endef
>> +
>> +VALGRIND_POST_INSTALL_TARGET_HOOKS += VALGRIND_REMOVE_TARGET_HEADERS
>> +
>>   ifeq ($(BR2_PACKAGE_VALGRIND_MEMCHECK),)
>>   define VALGRIND_REMOVE_MEMCHECK
>>   	rm -f $(TARGET_DIR)/usr/lib/valgrind/*memcheck*
>>
diff mbox series

Patch

diff --git a/package/valgrind/valgrind.mk b/package/valgrind/valgrind.mk
index cae14f79b9..8ee8c4585c 100644
--- a/package/valgrind/valgrind.mk
+++ b/package/valgrind/valgrind.mk
@@ -64,6 +64,12 @@  endef
 
 VALGRIND_POST_INSTALL_TARGET_HOOKS += VALGRIND_INSTALL_UCLIBC_SUPP
 
+define VALGRIND_REMOVE_TARGET_HEADERS
+	rm -rf $(TARGET_DIR)/usr/include/valgrind
+endef
+
+VALGRIND_POST_INSTALL_TARGET_HOOKS += VALGRIND_REMOVE_TARGET_HEADERS
+
 ifeq ($(BR2_PACKAGE_VALGRIND_MEMCHECK),)
 define VALGRIND_REMOVE_MEMCHECK
 	rm -f $(TARGET_DIR)/usr/lib/valgrind/*memcheck*