diff mbox series

package/mender: fix missing /var/lib

Message ID 20190215214253.28202-1-angelo@amarulasolutions.com
State Accepted
Headers show
Series package/mender: fix missing /var/lib | expand

Commit Message

Angelo Compagnucci Feb. 15, 2019, 9:42 p.m. UTC
Mender needs /var/lib directory to be available: on some configurations
/var/lib is not available and thus the mender package installation fails.
This patch does a mkdir to ensure the /var/lib directory is always
available.

Fixes:
http://autobuild.buildroot.net/results/02fde80f6b4bc57d5f2833bd979bf166252eab16
Signed-off-by: Angelo Compagnucci <angelo@amarulasolutions.com>
---
 package/mender/mender.mk | 1 +
 1 file changed, 1 insertion(+)

Comments

Thomas Petazzoni Feb. 15, 2019, 10 p.m. UTC | #1
Hello Angelo,

On Fri, 15 Feb 2019 22:42:53 +0100
Angelo Compagnucci <angelo.compagnucci@gmail.com> wrote:

> Mender needs /var/lib directory to be available: on some configurations
> /var/lib is not available and thus the mender package installation fails.
> This patch does a mkdir to ensure the /var/lib directory is always
> available.
> 
> Fixes:
> http://autobuild.buildroot.net/results/02fde80f6b4bc57d5f2833bd979bf166252eab16

This reference was a build failure on the "next" branch, so one might
think that the issue only exists on the next branch. So I've replaced
this with a reference to a build failure that happens on the "master"
branch, which makes it clear this patch should be applied on master.

Also for future patches: please always leave one blank line before your
SoB.

> Signed-off-by: Angelo Compagnucci <angelo@amarulasolutions.com>
> ---
>  package/mender/mender.mk | 1 +
>  1 file changed, 1 insertion(+)

Applied to master, thanks!

Thomas
diff mbox series

Patch

diff --git a/package/mender/mender.mk b/package/mender/mender.mk
index cd18c0055a..07f6e5e5f9 100644
--- a/package/mender/mender.mk
+++ b/package/mender/mender.mk
@@ -57,6 +57,7 @@  define MENDER_INSTALL_CONFIG_FILES
 	$(INSTALL) -D -m 0755 package/mender/device_type \
 			$(TARGET_DIR)/etc/mender/device_type
 
+	mkdir -p $(TARGET_DIR)/var/lib
 	ln -snf /var/run/mender $(TARGET_DIR)/var/lib/mender
 endef