diff mbox series

package/waf: purge trailig '/' from WAF_SITE

Message ID 20181210184559.13181-1-casantos@datacom.com.br
State Accepted
Headers show
Series package/waf: purge trailig '/' from WAF_SITE | expand

Commit Message

Carlos Santos Dec. 10, 2018, 6:45 p.m. UTC
<PKG>_SITE cannot have a trailing slash.

Signed-off-by: Carlos Santos <casantos@datacom.com.br>
---
 package/waf/waf.mk | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comments

Thomas Petazzoni Dec. 10, 2018, 7:45 p.m. UTC | #1
Hello,

On Mon, 10 Dec 2018 16:45:59 -0200, Carlos Santos wrote:
> <PKG>_SITE cannot have a trailing slash.
> 
> Signed-off-by: Carlos Santos <casantos@datacom.com.br>

Odd, why isn't our check in package/pkg-generic.mk for trailing slashes
triggering on this?

We have this:

ifeq ($$(patsubst %/,ERROR,$$($(2)_SITE)),ERROR)
$$(error $(2)_SITE ($$($(2)_SITE)) cannot have a trailing slash)
endif

Best regards,

Thomas
Arnout Vandecappelle Dec. 10, 2018, 8:59 p.m. UTC | #2
On 10/12/2018 20:45, Thomas Petazzoni wrote:
> Hello,
> 
> On Mon, 10 Dec 2018 16:45:59 -0200, Carlos Santos wrote:
>> <PKG>_SITE cannot have a trailing slash.
>>
>> Signed-off-by: Carlos Santos <casantos@datacom.com.br>
> 
> Odd, why isn't our check in package/pkg-generic.mk for trailing slashes
> triggering on this?
> 
> We have this:
> 
> ifeq ($$(patsubst %/,ERROR,$$($(2)_SITE)),ERROR)
> $$(error $(2)_SITE ($$($(2)_SITE)) cannot have a trailing slash)
> endif

 Because that check is within

ifeq ($$($$($(2)_KCONFIG_VAR)),y)
...
endif

and these packages are host-only packages.

 It has to be within that condition, since the _SITE may be set only or
differently based on kconfig options which are only set when the package is
selected. I tested and it fails for instance on arm-trusted-firmware if that
package is not selected.

 We need Config.in.host :-)

 Regards,
 Arnout
Thomas Petazzoni Dec. 10, 2018, 9:02 p.m. UTC | #3
Hello,

On Mon, 10 Dec 2018 21:59:37 +0100, Arnout Vandecappelle wrote:

>  Because that check is within
> 
> ifeq ($$($$($(2)_KCONFIG_VAR)),y)
> ...
> endif
> 
> and these packages are host-only packages.

Aah, indeed.

>  It has to be within that condition, since the _SITE may be set only or
> differently based on kconfig options which are only set when the package is
> selected. I tested and it fails for instance on arm-trusted-firmware if that
> package is not selected.
> 
>  We need Config.in.host :-)

Hehe, yes, we do :)

Best regards,

Thomas
Arnout Vandecappelle Dec. 10, 2018, 9:02 p.m. UTC | #4
On 10/12/2018 19:45, Carlos Santos wrote:
> <PKG>_SITE cannot have a trailing slash.
> 
> Signed-off-by: Carlos Santos <casantos@datacom.com.br>

 Committed to master after fixing the type in the commit title and adding an
explanation why this wasn't detected by the check in generic-package.

 Regards,
 Arnout

> ---
>  package/waf/waf.mk | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)
> 
> diff --git a/package/waf/waf.mk b/package/waf/waf.mk
> index cb738a38fd..97bc2a8963 100644
> --- a/package/waf/waf.mk
> +++ b/package/waf/waf.mk
> @@ -6,7 +6,7 @@
>  
>  WAF_VERSION = 1.9.5
>  WAF_SOURCE = waf-$(WAF_VERSION)
> -WAF_SITE = https://waf.io/
> +WAF_SITE = https://waf.io
>  
>  define HOST_WAF_EXTRACT_CMDS
>  	$(INSTALL) -D -m 0755 $(HOST_WAF_DL_DIR)/waf-$(WAF_VERSION) $(@D)/waf
>
diff mbox series

Patch

diff --git a/package/waf/waf.mk b/package/waf/waf.mk
index cb738a38fd..97bc2a8963 100644
--- a/package/waf/waf.mk
+++ b/package/waf/waf.mk
@@ -6,7 +6,7 @@ 
 
 WAF_VERSION = 1.9.5
 WAF_SOURCE = waf-$(WAF_VERSION)
-WAF_SITE = https://waf.io/
+WAF_SITE = https://waf.io
 
 define HOST_WAF_EXTRACT_CMDS
 	$(INSTALL) -D -m 0755 $(HOST_WAF_DL_DIR)/waf-$(WAF_VERSION) $(@D)/waf