diff mbox series

[next] tpm2-tss: fix build without stack smashing protection (SSP)

Message ID 20181119022624.22729-1-casantos@datacom.com.br
State Accepted
Headers show
Series [next] tpm2-tss: fix build without stack smashing protection (SSP) | expand

Commit Message

Carlos Santos Nov. 19, 2018, 2:26 a.m. UTC
Restore a configuration environment setup that was incorrectly removed
along with the upgrade to version 2.1.0.

Fixes:
  http://autobuild.buildroot.net/results/44221140fb8e2ddcb7d624e657b92a59375c02dd
  http://autobuild.buildroot.net/results/08b2a8a4bdd1c38703626a4fc37dab31dce98f49
  http://autobuild.buildroot.net/results/e469b47a6c8f1e8812325fd2860345105052316c
  http://autobuild.buildroot.net/results/f230fe6bbeb8b22d2b5b7cfb3f0ac4b3b936dc37
  http://autobuild.buildroot.net/results/ceb824033888086f6dde22c66d5b5f692a253c7e
  http://autobuild.buildroot.net/results/f863947a7384cb754706e6c346d222be59ad4136

Signed-off-by: Carlos Santos <casantos@datacom.ind.br>
---
 package/tpm2-tss/tpm2-tss.mk | 4 ++++
 1 file changed, 4 insertions(+)

Comments

Thomas Petazzoni Nov. 19, 2018, 8:51 p.m. UTC | #1
Hello,

On Mon, 19 Nov 2018 00:26:24 -0200, Carlos Santos wrote:
> Restore a configuration environment setup that was incorrectly removed
> along with the upgrade to version 2.1.0.
> 
> Fixes:
>   http://autobuild.buildroot.net/results/44221140fb8e2ddcb7d624e657b92a59375c02dd
>   http://autobuild.buildroot.net/results/08b2a8a4bdd1c38703626a4fc37dab31dce98f49
>   http://autobuild.buildroot.net/results/e469b47a6c8f1e8812325fd2860345105052316c
>   http://autobuild.buildroot.net/results/f230fe6bbeb8b22d2b5b7cfb3f0ac4b3b936dc37
>   http://autobuild.buildroot.net/results/ceb824033888086f6dde22c66d5b5f692a253c7e
>   http://autobuild.buildroot.net/results/f863947a7384cb754706e6c346d222be59ad4136
> 
> Signed-off-by: Carlos Santos <casantos@datacom.ind.br>
> ---
>  package/tpm2-tss/tpm2-tss.mk | 4 ++++
>  1 file changed, 4 insertions(+)

Applied to next, thanks.

Thomas
diff mbox series

Patch

diff --git a/package/tpm2-tss/tpm2-tss.mk b/package/tpm2-tss/tpm2-tss.mk
index 3bb0702916..f005e5d6b8 100644
--- a/package/tpm2-tss/tpm2-tss.mk
+++ b/package/tpm2-tss/tpm2-tss.mk
@@ -12,4 +12,8 @@  TPM2_TSS_INSTALL_STAGING = YES
 TPM2_TSS_DEPENDENCIES = liburiparser openssl host-pkgconf
 TPM2_TSS_CONF_OPTS = --with-crypto=ossl --disable-doxygen-doc
 
+# configure.ac doesn't contain a link test, so it doesn't detect when
+# libssp is missing.
+TPM2_TSS_CONF_ENV = ax_cv_check_cflags___________Wall__Werror_______fstack_protector_all=$(if $(BR2_TOOLCHAIN_HAS_SSP),yes,no)
+
 $(eval $(autotools-package))