diff mbox series

[1/1] boot/uboot: Set MAKE_ENV for kconfig build system

Message ID 20180905122236.26364-1-thomas.preston@codethink.co.uk
State Accepted
Headers show
Series [1/1] boot/uboot: Set MAKE_ENV for kconfig build system | expand

Commit Message

Thomas Preston Sept. 5, 2018, 12:22 p.m. UTC
U-Boot fails to build in a GitLab CI context because the kconfig-package
build stage is unable to find bison or flex even though they are
installed in HOST_DIR.

To fix this, set UBOOT_MAKE_ENV so that UBOOT_KCONFIG_MAKE uses the
correct PATH.

Signed-off-by: Thomas Preston <thomas.preston@codethink.co.uk>
---
 boot/uboot/uboot.mk | 1 +
 1 file changed, 1 insertion(+)

Comments

Thomas Petazzoni Sept. 5, 2018, 8:30 p.m. UTC | #1
Hello,

On Wed,  5 Sep 2018 13:22:36 +0100, Thomas Preston wrote:
> U-Boot fails to build in a GitLab CI context because the kconfig-package
> build stage is unable to find bison or flex even though they are
> installed in HOST_DIR.
> 
> To fix this, set UBOOT_MAKE_ENV so that UBOOT_KCONFIG_MAKE uses the
> correct PATH.
> 
> Signed-off-by: Thomas Preston <thomas.preston@codethink.co.uk>
> ---
>  boot/uboot/uboot.mk | 1 +
>  1 file changed, 1 insertion(+)

Applied to master, thanks.

Thomas
diff mbox series

Patch

diff --git a/boot/uboot/uboot.mk b/boot/uboot/uboot.mk
index bddafe234d..a19cb72458 100644
--- a/boot/uboot/uboot.mk
+++ b/boot/uboot/uboot.mk
@@ -449,6 +449,7 @@  endif # BR2_TARGET_UBOOT && BR_BUILDING
 ifeq ($(BR2_TARGET_UBOOT_BUILD_SYSTEM_LEGACY),y)
 $(eval $(generic-package))
 else ifeq ($(BR2_TARGET_UBOOT_BUILD_SYSTEM_KCONFIG),y)
+UBOOT_MAKE_ENV = $(TARGET_MAKE_ENV)
 UBOOT_KCONFIG_DEPENDENCIES = \
 	$(BR2_BISON_HOST_DEPENDENCY) \
 	$(BR2_FLEX_HOST_DEPENDENCY)