diff mbox series

[1/3] oracle-mysql: fix hostname path

Message ID 20180820111304.22933-2-chrismcc@gmail.com
State Accepted
Headers show
Series oracle-mysql bugfix, security fix, and enhancement | expand

Commit Message

Christopher McCrory Aug. 20, 2018, 11:13 a.m. UTC
Signed-off-by: Christopher McCrory <chrismcc@gmail.com>
---
 package/oracle-mysql/oracle-mysql.mk | 1 +
 1 file changed, 1 insertion(+)

Comments

Thomas Petazzoni Aug. 20, 2018, 6:21 p.m. UTC | #1
Hello Christopher,

On Mon, 20 Aug 2018 04:13:02 -0700, Christopher McCrory wrote:
> Signed-off-by: Christopher McCrory <chrismcc@gmail.com>

An empty commit log for such a change is really not good. What is
broken ? How does this fix what was broken ?

In general, a good rule: if your commit log is empty, something is
wrong.

So for this time, I've added a commit log and applied your patch to
master, see at
https://git.buildroot.org/buildroot/commit/?id=0bf656ead9801552f939217c5cc019fa24583b90
what I added. For your next contributions, I will now expect a
non-empty commit log actually explaining what the issue was, and how
the patch solves it.

Thanks,

Thomas
diff mbox series

Patch

diff --git a/package/oracle-mysql/oracle-mysql.mk b/package/oracle-mysql/oracle-mysql.mk
index 7da5c547d9..0275a8428f 100644
--- a/package/oracle-mysql/oracle-mysql.mk
+++ b/package/oracle-mysql/oracle-mysql.mk
@@ -21,6 +21,7 @@  MYSQL_SOCKET = /run/mysql/mysql.sock
 ORACLE_MYSQL_CONF_ENV = \
 	ac_cv_sys_restartable_syscalls=yes \
 	ac_cv_path_PS=/bin/ps \
+	ac_cv_path_HOSTNAME=/bin/hostname \
 	ac_cv_FIND_PROC="/bin/ps p \$\$PID | grep -v grep | grep mysqld > /dev/null" \
 	ac_cv_have_decl_HAVE_IB_ATOMIC_PTHREAD_T_GCC=yes \
 	ac_cv_have_decl_HAVE_IB_ATOMIC_PTHREAD_T_SOLARIS=no \