diff mbox series

[01/17] perl-cgi: add host

Message ID 20180811182749.20924-2-chrismcc@gmail.com
State Rejected
Headers show
Series even more perl modules | expand

Commit Message

Christopher McCrory Aug. 11, 2018, 6:27 p.m. UTC
Signed-off-by: Christopher McCrory <chrismcc@gmail.com>
---
 package/perl-cgi/perl-cgi.mk | 2 ++
 1 file changed, 2 insertions(+)

Comments

Thomas Petazzoni Aug. 12, 2018, 12:11 p.m. UTC | #1
Hello Christopher,

On Sat, 11 Aug 2018 11:27:33 -0700, Christopher McCrory wrote:
> Signed-off-by: Christopher McCrory <chrismcc@gmail.com>
> ---
>  package/perl-cgi/perl-cgi.mk | 2 ++
>  1 file changed, 2 insertions(+)
> 
> diff --git a/package/perl-cgi/perl-cgi.mk b/package/perl-cgi/perl-cgi.mk
> index b8115de6ad..476f5f69c3 100644
> --- a/package/perl-cgi/perl-cgi.mk
> +++ b/package/perl-cgi/perl-cgi.mk
> @@ -8,7 +8,9 @@ PERL_CGI_VERSION = 4.38
>  PERL_CGI_SOURCE = CGI-$(PERL_CGI_VERSION).tar.gz
>  PERL_CGI_SITE = $(BR2_CPAN_MIRROR)/authors/id/L/LE/LEEJO
>  PERL_CGI_DEPENDENCIES = perl-html-parser
> +HOST_PERL_CGI_DEPENDENCIES = host-perl-html-parser

host-perl-html-parser does not exist, until PATCH 02/17 of this series.
Therefore, the order of the patches in your series is not good, and the
series is not bisectable. If I apply only PATCH 01/17, things are
broken because host-perl-cgi-perl will try to build
host-perl-html-parser, which doesn't exist.

Please be careful when ordering the patches: they should be organized
in the correct order to make sure that everything builds at every point
of the series.

In this specific example, you should have the following order:

 (1) Introduce host-perl-html-tagset

 (2) Introduce host-perl-html-parser, which uses host-perl-html-tagset

 (3) Introduce host-perl-cgi, which uses host-perl-html-parser

Does that make sense ?

Thanks!

Thomas
Christopher McCrory Aug. 13, 2018, 1:23 p.m. UTC | #2
hello

On Sun, Aug 12, 2018 at 5:11 AM, Thomas Petazzoni <
thomas.petazzoni@bootlin.com> wrote:

> Hello Christopher,
>
> On Sat, 11 Aug 2018 11:27:33 -0700, Christopher McCrory wrote:
> > Signed-off-by: Christopher McCrory <chrismcc@gmail.com>
> > ---
> >  package/perl-cgi/perl-cgi.mk | 2 ++
> >  1 file changed, 2 insertions(+)
>
>
> Please be careful when ordering the patches: they should be organized
> in the correct order to make sure that everything builds at every point
> of the series.
>
>

Sorry about that, I did spend a lot of time getting them in the correct
order.  Somehow I missed this one.  After a while they all started bluring
together :)





> In this specific example, you should have the following order:
>
>  (1) Introduce host-perl-html-tagset
>
>  (2) Introduce host-perl-html-parser, which uses host-perl-html-tagset
>
>  (3) Introduce host-perl-cgi, which uses host-perl-html-parser
>
> Does that make sense ?
>
> Thanks!
>
> Thomas
> --
> Thomas Petazzoni, CTO, Bootlin (formerly Free Electrons)
> Embedded Linux and Kernel engineering
> https://bootlin.com
>
diff mbox series

Patch

diff --git a/package/perl-cgi/perl-cgi.mk b/package/perl-cgi/perl-cgi.mk
index b8115de6ad..476f5f69c3 100644
--- a/package/perl-cgi/perl-cgi.mk
+++ b/package/perl-cgi/perl-cgi.mk
@@ -8,7 +8,9 @@  PERL_CGI_VERSION = 4.38
 PERL_CGI_SOURCE = CGI-$(PERL_CGI_VERSION).tar.gz
 PERL_CGI_SITE = $(BR2_CPAN_MIRROR)/authors/id/L/LE/LEEJO
 PERL_CGI_DEPENDENCIES = perl-html-parser
+HOST_PERL_CGI_DEPENDENCIES = host-perl-html-parser
 PERL_CGI_LICENSE = Artistic or GPL-1.0+
 PERL_CGI_LICENSE_FILES = LICENSE
 
 $(eval $(perl-package))
+$(eval $(host-perl-package))