diff mbox series

package/dhcp: copy dhcpctl and omapi libraries and headers into staging

Message ID 20180626154145.27019-1-daniel@0x0f.com
State Changes Requested
Headers show
Series package/dhcp: copy dhcpctl and omapi libraries and headers into staging | expand

Commit Message

Daniel Palmer June 26, 2018, 3:41 p.m. UTC
---
 package/dhcp/dhcp.mk | 21 +++++++++++++++++++++
 1 file changed, 21 insertions(+)

Comments

Baruch Siach June 26, 2018, 6:41 p.m. UTC | #1
Hi Daniel,

Thanks for your contribution. A few comment on your patch below.

On Wed, Jun 27, 2018 at 12:41:45AM +0900, Daniel Palmer wrote:

Please explain in the commit log why you need this change.

You also need to sign-off your patch.

baruch

> ---
>  package/dhcp/dhcp.mk | 21 +++++++++++++++++++++
>  1 file changed, 21 insertions(+)
> 
> diff --git a/package/dhcp/dhcp.mk b/package/dhcp/dhcp.mk
> index a1285184d3..dac7235f08 100644
> --- a/package/dhcp/dhcp.mk
> +++ b/package/dhcp/dhcp.mk
> @@ -118,4 +118,25 @@ define DHCP_INSTALL_TARGET_CMDS
>  	$(DHCP_INSTALL_CLIENT)
>  endef
>  
> +define DHCP_INSTALL_STAGING_CMDS
> +	$(INSTALL) -D -m 644 $(@D)/dhcpctl/dhcpctl.h \
> +		$(HOST_DIR)/usr/include/dhcpctl/dhcpctl.h
> +	$(INSTALL) -D -m 644 $(@D)/includes/isc-dhcp/dst.h \
> +		$(HOST_DIR)/usr/include/isc-dhcp/dst.h
> +	$(INSTALL) -D -m 644 -t $(HOST_DIR)/usr/include/omapip/ \
> +		$(@D)/includes/omapip/alloc.h \
> +		$(@D)/includes/omapip/buffer.h \
> +		$(@D)/includes/omapip/convert.h \
> +		$(@D)/includes/omapip/hash.h \
> +		$(@D)/includes/omapip/isclib.h \
> +		$(@D)/includes/omapip/omapip.h \
> +		$(@D)/includes/omapip/omapip_p.h \
> +		$(@D)/includes/omapip/result.h \
> +		$(@D)/includes/omapip/trace.h
> +	$(INSTALL) -D -m 644 $(@D)/dhcpctl/libdhcpctl.a \
> +		$(HOST_DIR)/usr/lib/libdhcpctl.a
> +	$(INSTALL) -D -m 644 $(@D)/omapip/libomapi.a \
> +		$(HOST_DIR)/usr/lib/libomapi.a
> +endef
> +
>  $(eval $(autotools-package))
diff mbox series

Patch

diff --git a/package/dhcp/dhcp.mk b/package/dhcp/dhcp.mk
index a1285184d3..dac7235f08 100644
--- a/package/dhcp/dhcp.mk
+++ b/package/dhcp/dhcp.mk
@@ -118,4 +118,25 @@  define DHCP_INSTALL_TARGET_CMDS
 	$(DHCP_INSTALL_CLIENT)
 endef
 
+define DHCP_INSTALL_STAGING_CMDS
+	$(INSTALL) -D -m 644 $(@D)/dhcpctl/dhcpctl.h \
+		$(HOST_DIR)/usr/include/dhcpctl/dhcpctl.h
+	$(INSTALL) -D -m 644 $(@D)/includes/isc-dhcp/dst.h \
+		$(HOST_DIR)/usr/include/isc-dhcp/dst.h
+	$(INSTALL) -D -m 644 -t $(HOST_DIR)/usr/include/omapip/ \
+		$(@D)/includes/omapip/alloc.h \
+		$(@D)/includes/omapip/buffer.h \
+		$(@D)/includes/omapip/convert.h \
+		$(@D)/includes/omapip/hash.h \
+		$(@D)/includes/omapip/isclib.h \
+		$(@D)/includes/omapip/omapip.h \
+		$(@D)/includes/omapip/omapip_p.h \
+		$(@D)/includes/omapip/result.h \
+		$(@D)/includes/omapip/trace.h
+	$(INSTALL) -D -m 644 $(@D)/dhcpctl/libdhcpctl.a \
+		$(HOST_DIR)/usr/lib/libdhcpctl.a
+	$(INSTALL) -D -m 644 $(@D)/omapip/libomapi.a \
+		$(HOST_DIR)/usr/lib/libomapi.a
+endef
+
 $(eval $(autotools-package))