diff mbox series

[v2] libiio: fix libavahi-client dependency

Message ID 20171227123555.15388-1-marcus.folkesson@gmail.com
State Accepted
Headers show
Series [v2] libiio: fix libavahi-client dependency | expand

Commit Message

Marcus Folkesson Dec. 27, 2017, 12:35 p.m. UTC
Avahi needs avahi-daemon and D-Bus to build avahi-client.

Signed-off-by: Marcus Folkesson <marcus.folkesson@gmail.com>
---
v2:
- Do not check for AVAHI as it is implicity checked by
  AVAHI_DAEMON

 package/libiio/libiio.mk | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

Comments

Thomas Petazzoni Dec. 30, 2017, 5:32 p.m. UTC | #1
Hello,

On Wed, 27 Dec 2017 13:35:55 +0100, Marcus Folkesson wrote:
> Avahi needs avahi-daemon and D-Bus to build avahi-client.
> 
> Signed-off-by: Marcus Folkesson <marcus.folkesson@gmail.com>
> ---
> v2:
> - Do not check for AVAHI as it is implicity checked by
>   AVAHI_DAEMON

Applied to master, thanks.

Thomas
Peter Korsgaard Jan. 8, 2018, 9:47 p.m. UTC | #2
>>>>> "Marcus" == Marcus Folkesson <marcus.folkesson@gmail.com> writes:

 > Avahi needs avahi-daemon and D-Bus to build avahi-client.
 > Signed-off-by: Marcus Folkesson <marcus.folkesson@gmail.com>
 > ---
 > v2:
 > - Do not check for AVAHI as it is implicity checked by
 >   AVAHI_DAEMON

Committed to 2017.11.x, thanks.
Peter Korsgaard Jan. 29, 2018, 9:35 p.m. UTC | #3
>>>>> "Marcus" == Marcus Folkesson <marcus.folkesson@gmail.com> writes:

 > Avahi needs avahi-daemon and D-Bus to build avahi-client.
 > Signed-off-by: Marcus Folkesson <marcus.folkesson@gmail.com>
 > ---
 > v2:
 > - Do not check for AVAHI as it is implicity checked by
 >   AVAHI_DAEMON

Committed to 2017.02.x, thanks.
diff mbox series

Patch

diff --git a/package/libiio/libiio.mk b/package/libiio/libiio.mk
index 0b13064085..3fbd39188a 100644
--- a/package/libiio/libiio.mk
+++ b/package/libiio/libiio.mk
@@ -54,8 +54,8 @@  else
 LIBIIO_CONF_OPTS += -DWITH_IIOD_USBD=OFF
 endif
 
-# Avahi support in libiio requires avahi-client, which needs avahi-daemon
-ifeq ($(BR2_PACKAGE_AVAHI)$(BR2_PACKAGE_AVAHI_DAEMON),yy)
+# Avahi support in libiio requires avahi-client, which needs avahi-daemon and dbus
+ifeq ($(BR2_PACKAGE_AVAHI_DAEMON)$(BR2_PACKAGE_DBUS),yy)
 LIBIIO_DEPENDENCIES += avahi
 endif