diff mbox series

[1/2] package/nodejs: bump version to 8.9.1

Message ID 20171108112542.8163-1-martin@barkynet.com
State Accepted
Commit 582496635cd26678f8c1b9a48b73c0e1d8534d01
Headers show
Series [1/2] package/nodejs: bump version to 8.9.1 | expand

Commit Message

Martin Bark Nov. 8, 2017, 11:25 a.m. UTC
See https://nodejs.org/en/blog/release/v8.9.1/

Signed-off-by: Martin Bark <martin@barkynet.com>
---
 package/nodejs/nodejs.hash | 4 ++--
 package/nodejs/nodejs.mk   | 2 +-
 2 files changed, 3 insertions(+), 3 deletions(-)

Comments

Peter Korsgaard Nov. 8, 2017, 12:25 p.m. UTC | #1
>>>>> "Martin" == Martin Bark <martin@barkynet.com> writes:

 > See https://nodejs.org/en/blog/release/v8.9.1/
 > Signed-off-by: Martin Bark <martin@barkynet.com>

Are these meant for master or next? The nodejs bump looks like master
material to me, but what about libuv? Does the new nodejs version depend
on the libuv bump?
Martin Bark Nov. 8, 2017, 3:55 p.m. UTC | #2
Hi,

On 8 November 2017 at 12:25, Peter Korsgaard <peter@korsgaard.com> wrote:
>>>>>> "Martin" == Martin Bark <martin@barkynet.com> writes:
>
>  > See https://nodejs.org/en/blog/release/v8.9.1/
>  > Signed-off-by: Martin Bark <martin@barkynet.com>
>
> Are these meant for master or next? The nodejs bump looks like master
> material to me, but what about libuv? Does the new nodejs version depend
> on the libuv bump?

I would prefer master but if you can't because of the 2017.11 release
then i'm fine with next.

Yes the nodejs version needs the libuv bump.  nodejs 8.9.1 includes a
cherry picked patch from libuv which is present in the 1.16.0 release.

Thanks

Martin

>
> --
> Bye, Peter Korsgaard
Peter Korsgaard Nov. 8, 2017, 6:46 p.m. UTC | #3
>>>>> "Martin" == Martin Bark <martin@barkynet.com> writes:

 > Hi,
 > On 8 November 2017 at 12:25, Peter Korsgaard <peter@korsgaard.com> wrote:
 >>>>>>> "Martin" == Martin Bark <martin@barkynet.com> writes:
 >> 
 >> > See https://nodejs.org/en/blog/release/v8.9.1/
 >> > Signed-off-by: Martin Bark <martin@barkynet.com>
 >> 
 >> Are these meant for master or next? The nodejs bump looks like master
 >> material to me, but what about libuv? Does the new nodejs version depend
 >> on the libuv bump?

 > I would prefer master but if you can't because of the 2017.11 release
 > then i'm fine with next.

 > Yes the nodejs version needs the libuv bump.  nodejs 8.9.1 includes a
 > cherry picked patch from libuv which is present in the 1.16.0 release.

Ok - Committed both to master then, thanks.
diff mbox series

Patch

diff --git a/package/nodejs/nodejs.hash b/package/nodejs/nodejs.hash
index 9367c543be..658f80baaa 100644
--- a/package/nodejs/nodejs.hash
+++ b/package/nodejs/nodejs.hash
@@ -1,2 +1,2 @@ 
-# From http://nodejs.org/dist/v8.8.1/SHASUMS256.txt
-sha256 5ce2c47ab779992db49942f757a01cc5131db5cef4e0dd270e48151b0887b57a  node-v8.8.1.tar.xz
+# From http://nodejs.org/dist/v8.9.1/SHASUMS256.txt
+sha256 ef160c21f60f8aca64145985e01b4044435e381dc16e8f0640ed0223e84f17e0  node-v8.9.1.tar.xz
diff --git a/package/nodejs/nodejs.mk b/package/nodejs/nodejs.mk
index a29f5726cc..9cf26da601 100644
--- a/package/nodejs/nodejs.mk
+++ b/package/nodejs/nodejs.mk
@@ -4,7 +4,7 @@ 
 #
 ################################################################################
 
-NODEJS_VERSION = 8.8.1
+NODEJS_VERSION = 8.9.1
 NODEJS_SOURCE = node-v$(NODEJS_VERSION).tar.xz
 NODEJS_SITE = http://nodejs.org/dist/v$(NODEJS_VERSION)
 NODEJS_DEPENDENCIES = host-python host-nodejs c-ares \