diff mbox

package/mpd: fix static linking with tremor

Message ID 20170110222342.21045-1-joerg.krause@embedded.rocks
State Superseded
Headers show

Commit Message

Jörg Krause Jan. 10, 2017, 10:23 p.m. UTC
Although tremor (the library is named vorbisidec) provides a pkg-config
file, mpd does not use it to find tremor. Since version 0.20 does throw
an error instead of a warning, that's why the issue was left unnoticed
by the autobuilders.

Help mpd to find tremor by providing the path to the library and passing
LIBS through the environment. We use the host pkg-config tool to get the
correct values from the vorbisidec.pc file.

Signed-off-by: Jörg Krause <joerg.krause@embedded.rocks>
---
 package/mpd/mpd.mk | 5 ++++-
 1 file changed, 4 insertions(+), 1 deletion(-)
diff mbox

Patch

diff --git a/package/mpd/mpd.mk b/package/mpd/mpd.mk
index 10e6b90dd..bee68436d 100644
--- a/package/mpd/mpd.mk
+++ b/package/mpd/mpd.mk
@@ -222,7 +222,10 @@  endif
 
 ifeq ($(BR2_PACKAGE_MPD_TREMOR),y)
 MPD_DEPENDENCIES += tremor
-MPD_CONF_OPTS += --with-tremor
+# Help mpd to find tremor in static linking scenarios
+MPD_CONF_ENV += \
+	TREMOR_LIBS="`$(PKG_CONFIG_HOST_BINARY) --libs vorbisidec`"
+MPD_CONF_OPTS += --with-tremor=$(STAGING_DIR)/usr
 endif
 
 ifeq ($(BR2_PACKAGE_MPD_TWOLAME),y)