diff mbox

[2/3] package/ola: disable fatal warnings for host variant

Message ID 20160921233143.28149-2-joerg.krause@embedded.rocks
State Accepted
Headers show

Commit Message

Jörg Krause Sept. 21, 2016, 11:31 p.m. UTC
By default the build system of OLA passes '-Werror' to GCC. The aborts
compilation with GCC 6:

'''
error: ‘template<class> class std::auto_ptr’ is deprecated
[-Werror=deprecated-declarations]
'''

The target variant already passes the option "-disable-fatal-warnings"
to the build system to disable '-Werror'. Do it for the host variant to
to fix build with host GCC 6.

Signed-off-by: Jörg Krause <joerg.krause@embedded.rocks>
---
 package/ola/ola.mk | 3 ++-
 1 file changed, 2 insertions(+), 1 deletion(-)
diff mbox

Patch

diff --git a/package/ola/ola.mk b/package/ola/ola.mk
index 6f62a17..75ab25e 100644
--- a/package/ola/ola.mk
+++ b/package/ola/ola.mk
@@ -40,7 +40,8 @@  HOST_OLA_CONF_OPTS = \
 	--disable-examples \
 	--disable-unittests \
 	--disable-doxygen-html \
-	--disable-doxygen-doc
+	--disable-doxygen-doc \
+	--disable-fatal-warnings
 
 # On the host side, we only need ola_protoc_plugin, so build and install this
 # only.