diff mbox

[git,commit] sudo: bump to version 1.8.4p4

Message ID 20120329154644.B0407969A7@busybox.osuosl.org
State Not Applicable
Headers show

Commit Message

Peter Korsgaard March 29, 2012, 3:46 p.m. UTC
commit: http://git.buildroot.net/buildroot/commit/?id=61d3d740dba46f469ea368b9080091ce614455a8
branch: http://git.buildroot.net/buildroot/commit/?id=refs/heads/master

Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
---
 package/sudo/sudo.mk |   11 ++++++-----
 1 files changed, 6 insertions(+), 5 deletions(-)

Comments

Thomas Petazzoni March 29, 2012, 11:15 p.m. UTC | #1
Le Thu, 29 Mar 2012 17:46:25 +0200,
Peter Korsgaard <jacmet@sunsite.dk> a écrit :

> commit: http://git.buildroot.net/buildroot/commit/?id=61d3d740dba46f469ea368b9080091ce614455a8
> branch: http://git.buildroot.net/buildroot/commit/?id=refs/heads/master
> 
> Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>

I don't know if it is caused by this bump version or if the problem was
present before, but:

 http://autobuild.buildroot.org/results/d5a7831701e4c3b147451f4f021aa644672005ae/build-end.log
 http://autobuild.buildroot.org/results/521b2a317fe2464c13e6fecd0c80ee2bac229522/build-end.log
 http://autobuild.buildroot.org/results/10469a7a62f43200e17d94fcb0460f2e032bac4d/build-end.log

I don't think I have seen sudo build failures before this bump through
the autobuild tests.

Best regards,

Thomas
Peter Korsgaard March 30, 2012, 6:27 a.m. UTC | #2
>>>>> "Thomas" == Thomas Petazzoni <thomas.petazzoni@free-electrons.com> writes:

 Thomas> I don't know if it is caused by this bump version or if the
 Thomas> problem was present before, but:

 Thomas>  http://autobuild.buildroot.org/results/d5a7831701e4c3b147451f4f021aa644672005ae/build-end.log
 Thomas>  http://autobuild.buildroot.org/results/521b2a317fe2464c13e6fecd0c80ee2bac229522/build-end.log
 Thomas>  http://autobuild.buildroot.org/results/10469a7a62f43200e17d94fcb0460f2e032bac4d/build-end.log

 Thomas> I don't think I have seen sudo build failures before this bump through
 Thomas> the autobuild tests.

The new sudo needs the utmpx stuff I recently added to the uClibc
defconfigs for systemd. I will rebuild my i686 toolchain on gcc110
today.
Thomas Petazzoni March 30, 2012, 6:28 a.m. UTC | #3
Le Fri, 30 Mar 2012 08:27:22 +0200,
Peter Korsgaard <jacmet@uclibc.org> a écrit :

> The new sudo needs the utmpx stuff I recently added to the uClibc
> defconfigs for systemd. I will rebuild my i686 toolchain on gcc110
> today.

Ok, then I guess I will have similar problems with my uClibc-based
external toolchains. I'll try to fix that.

Regards,

Thomas
Gustavo Zacarias March 30, 2012, 9:59 a.m. UTC | #4
On 2012-03-30 03:27, Peter Korsgaard wrote:

>  Thomas> I don't think I have seen sudo build failures before this
> bump through
>  Thomas> the autobuild tests.
>
> The new sudo needs the utmpx stuff I recently added to the uClibc
> defconfigs for systemd. I will rebuild my i686 toolchain on gcc110
> today.

In theory they work around it when it's not present, lines 60-68 of 
utmp.c:

/*
  * Simplify handling of utmp vs. utmpx
  */
#if !defined(HAVE_GETUTXID) && defined(HAVE_GETUTID)
# define getutxline(u)  getutline(u)
# define pututxline(u)  pututline(u)
# define setutxent      setutent(u)
# define endutxent      endutent(u)
#endif /* !HAVE_GETUTXID && HAVE_GETUTID */

However the defines for setutxent & endutxent are inconsistent it 
seems.
Regards.
diff mbox

Patch

diff --git a/package/sudo/sudo.mk b/package/sudo/sudo.mk
index f10d294..71d7a20 100644
--- a/package/sudo/sudo.mk
+++ b/package/sudo/sudo.mk
@@ -4,9 +4,8 @@ 
 #
 #############################################################
 
-SUDO_VERSION = 1.7.8p1
+SUDO_VERSION = 1.8.4p4
 SUDO_SITE    = http://www.sudo.ws/sudo/dist
-
 SUDO_CONF_OPT = \
 		--without-lecture \
 		--without-sendmail \
@@ -16,9 +15,11 @@  SUDO_CONF_OPT = \
 		--without-pam
 
 define SUDO_INSTALL_TARGET_CMDS
-	install -m 4555 -D $(@D)/sudo $(TARGET_DIR)/usr/bin/sudo
-	install -m 0555 -D $(@D)/visudo $(TARGET_DIR)/usr/sbin/visudo
-	install -m 0440 -D $(@D)/sudoers $(TARGET_DIR)/etc/sudoers
+	install -m 4555 -D $(@D)/src/sudo $(TARGET_DIR)/usr/bin/sudo
+	install -m 0555 -D $(@D)/plugins/sudoers/visudo  \
+		$(TARGET_DIR)/usr/sbin/visudo
+	install -m 0440 -D $(@D)/plugins/sudoers/sudoers \
+		$(TARGET_DIR)/etc/sudoers
 endef
 
 $(eval $(call AUTOTARGETS))