diff mbox series

package/grep: fix busybox aliasing

Message ID 1580813230-11405-1-git-send-email-angelo@amarulasolutions.com
State Changes Requested
Headers show
Series package/grep: fix busybox aliasing | expand

Commit Message

Angelo Compagnucci Feb. 4, 2020, 10:47 a.m. UTC
When grep package is selected, it should be installed at the same exact
location where busybox installs it too, this way the grep/egrep/fgrep
executables will end up overwriting the busybox provided ones.
Busybox installs *grep executables in /bin, grep package in /usr/bin.

Moreover, egrep/fgrep is using autotools SHELL variable to execve the
grep executable with correct options, SHELL is defaulted to /bin/bash
which is usually not available on target.

Signed-off-by: Angelo Compagnucci <angelo@amarulasolutions.com>
---
 package/grep/grep.mk | 1 +
 1 file changed, 1 insertion(+)

Comments

Peter Korsgaard Feb. 4, 2020, 12:57 p.m. UTC | #1
>>>>> "Angelo" == Angelo Compagnucci <angelo@amarulasolutions.com> writes:

 > When grep package is selected, it should be installed at the same exact
 > location where busybox installs it too, this way the grep/egrep/fgrep
 > executables will end up overwriting the busybox provided ones.
 > Busybox installs *grep executables in /bin, grep package in /usr/bin.

 > Moreover, egrep/fgrep is using autotools SHELL variable to execve the
 > grep executable with correct options, SHELL is defaulted to /bin/bash
 > which is usually not available on target.

"Moreover" in a commit message is quite a strong hint that the commit is
doing several things ;)

Can you split it up into two commits, one for the prefix issue and one
for the SHELL issue?

I take it that you checked that the configure logic works with
SHELL=/bin/sh when that ISN'T bash?


 > Signed-off-by: Angelo Compagnucci <angelo@amarulasolutions.com>
 > ---
 >  package/grep/grep.mk | 1 +
 >  1 file changed, 1 insertion(+)

 > diff --git a/package/grep/grep.mk b/package/grep/grep.mk
 > index 96685b0..7365a57 100644
 > --- a/package/grep/grep.mk
 > +++ b/package/grep/grep.mk
 > @@ -10,6 +10,7 @@ GREP_SOURCE = grep-$(GREP_VERSION).tar.xz
 >  GREP_LICENSE = GPL-3.0+
 >  GREP_LICENSE_FILES = COPYING
 >  GREP_DEPENDENCIES = $(TARGET_NLS_DEPENDENCIES)
 > +GREP_CONF_OPTS = SHELL=/bin/sh --exec-prefix=/
 
 >  # link with iconv if enabled
 >  ifeq ($(BR2_PACKAGE_LIBICONV),y)
 > -- 
 > 2.7.4

 > _______________________________________________
 > buildroot mailing list
 > buildroot@busybox.net
 > http://lists.busybox.net/mailman/listinfo/buildroot
diff mbox series

Patch

diff --git a/package/grep/grep.mk b/package/grep/grep.mk
index 96685b0..7365a57 100644
--- a/package/grep/grep.mk
+++ b/package/grep/grep.mk
@@ -10,6 +10,7 @@  GREP_SOURCE = grep-$(GREP_VERSION).tar.xz
 GREP_LICENSE = GPL-3.0+
 GREP_LICENSE_FILES = COPYING
 GREP_DEPENDENCIES = $(TARGET_NLS_DEPENDENCIES)
+GREP_CONF_OPTS = SHELL=/bin/sh --exec-prefix=/
 
 # link with iconv if enabled
 ifeq ($(BR2_PACKAGE_LIBICONV),y)