diff mbox series

package/pkg-kconfig: fix reconfigure for kconfig packages

Message ID 1574765013-15209-1-git-send-email-angelo@amarulasolutions.com
State Superseded
Headers show
Series package/pkg-kconfig: fix reconfigure for kconfig packages | expand

Commit Message

Angelo Compagnucci Nov. 26, 2019, 10:43 a.m. UTC
From: Angelo Compagnucci <angelo.compagnucci@gmail.com>

Kconfig based packages are not really reconfigured if the .config file is not
regenerated in the reconfigure target.

Signed-off-by: Angelo Compagnucci <angelo@amarulasolutions.com>
---
 package/pkg-kconfig.mk | 1 +
 1 file changed, 1 insertion(+)

Comments

Thomas Petazzoni Nov. 26, 2019, 11:48 a.m. UTC | #1
On Tue, 26 Nov 2019 11:43:33 +0100
Angelo Compagnucci <angelo@amarulasolutions.com> wrote:

> From: Angelo Compagnucci <angelo.compagnucci@gmail.com>
> 
> Kconfig based packages are not really reconfigured if the .config file is not
> regenerated in the reconfigure target.

I think the commit log could be improved, with at least a reference to
4b81badbcc0b25678ac6627548160702731cf393, which says:

    Currently, calling foo-reconfigure for a kconfig-based package will not
    re-trigger the configuration (kconfig-wise) step for the package.

However, the implementation consisted in removing just the
.stamp_kconfig_fixup_done, so only the kconfig fixups get redone on
-reconfigure, not a full regeneration of the configuration.

Right now the commit log is not really clear on what is happening
today, why it is considered not good, and what is the new proposed
behavior.

>  $(1)-clean-kconfig-for-reconfigure:
>  	rm -f $$($(2)_DIR)/.stamp_kconfig_fixup_done

You can remove this line, it is no longer needed.

> +	rm -f $$($(2)_DIR)/.stamp_dotconfig

Use:

	rm -rf $$($(2)_DIR)/$$($(2)_KCONFIG_STAMP_DOTCONFIG)

instead.

Thanks.

Thomas
diff mbox series

Patch

diff --git a/package/pkg-kconfig.mk b/package/pkg-kconfig.mk
index 86d7c14..91cc606 100644
--- a/package/pkg-kconfig.mk
+++ b/package/pkg-kconfig.mk
@@ -176,6 +176,7 @@  $(1)-clean-for-reconfigure: $(1)-clean-kconfig-for-reconfigure
 
 $(1)-clean-kconfig-for-reconfigure:
 	rm -f $$($(2)_DIR)/.stamp_kconfig_fixup_done
+	rm -f $$($(2)_DIR)/.stamp_dotconfig
 
 # Only enable the foo-*config targets when the package is actually enabled.
 # Note: the variable $(2)_KCONFIG_VAR is not related to the kconfig