diff mbox series

[PATCH/next,1/1] package/libubootenv: fix build with musl and static lib

Message ID 1558455512-31444-1-git-send-email-pjtexier@koncepto.io
State Changes Requested
Headers show
Series [PATCH/next,1/1] package/libubootenv: fix build with musl and static lib | expand

Commit Message

Pierre-Jean Texier May 21, 2019, 4:18 p.m. UTC
Libubootenv is a shared library, so add missing dependency on !BR2_STATIC_LIBS.

Also add BR2_TOOLCHAIN_USES_MUSL dependency to avoid 'unknown type name 'loff_t''.

Fixes:
 - http://autobuild.buildroot.net/results/206/206f1eba0dec39de1c02d760fa8f961d5a3879d0/
 - http://autobuild.buildroot.net/results/8a6/8a6b3087a4c2cb53f4e9b80183c7f4b0ea6ffd3b/

Signed-off-by: Pierre-Jean Texier <pjtexier@koncepto.io>
---
 package/libubootenv/Config.in | 5 +++++
 1 file changed, 5 insertions(+)

Comments

Thomas Petazzoni May 21, 2019, 6:59 p.m. UTC | #1
Hello Pierre-Jean,

On Tue, 21 May 2019 18:18:32 +0200
Pierre-Jean Texier <pjtexier@koncepto.io> wrote:

> Libubootenv is a shared library, so add missing dependency on !BR2_STATIC_LIBS.

I think instead src/CMakeLists.txt should be changed to not force
building a shared library.

> Also add BR2_TOOLCHAIN_USES_MUSL dependency to avoid 'unknown type name 'loff_t''.

And here I'm pretty sure musl provides loff_t, it's probably just a
missing #include.

> +comment "libubootenv application library needs a glibc or uClibc toolchain w/ dynamic library"

The correct comment would be:

comment "libubootenv needs a glibc or uClibc toolchain w/ dynamic library"

but I think it's better to fix the actual problems.

Best regards,

Thomas
Pierre-Jean Texier May 21, 2019, 7:53 p.m. UTC | #2
Hello Thomas,

Le 21/05/2019 à 20:59, Thomas Petazzoni a écrit :
> Hello Pierre-Jean,
>
> On Tue, 21 May 2019 18:18:32 +0200
> Pierre-Jean Texier <pjtexier@koncepto.io> wrote:
>
>> Libubootenv is a shared library, so add missing dependency on !BR2_STATIC_LIBS.
> I think instead src/CMakeLists.txt should be changed to not force
> building a shared library.
Ok, I will do.
>
>> Also add BR2_TOOLCHAIN_USES_MUSL dependency to avoid 'unknown type name 'loff_t''.
> And here I'm pretty sure musl provides loff_t, it's probably just a
> missing #include.
In fact yes, we have to define _GNU_SOURCE.
I'll prepare a patch to fix this issue.
>
>> +comment "libubootenv application library needs a glibc or uClibc toolchain w/ dynamic library"
> The correct comment would be:
>
> comment "libubootenv needs a glibc or uClibc toolchain w/ dynamic library"
>
> but I think it's better to fix the actual problems.

No problem, I will send a v2 tomorrow.

Thanks

Pierre-Jean
>
> Best regards,
>
> Thomas
diff mbox series

Patch

diff --git a/package/libubootenv/Config.in b/package/libubootenv/Config.in
index 9be52c4..bad5aee 100644
--- a/package/libubootenv/Config.in
+++ b/package/libubootenv/Config.in
@@ -1,5 +1,7 @@ 
 config BR2_PACKAGE_LIBUBOOTENV
 	bool "libubootenv"
+	depends on !BR2_STATIC_LIBS
+	depends on !BR2_TOOLCHAIN_USES_MUSL # loff_t
 	select BR2_PACKAGE_ZLIB
 	help
 	  libubootenv is a library that provides a hardware independent
@@ -9,3 +11,6 @@  config BR2_PACKAGE_LIBUBOOTENV
 	  new tools build from the library and not from U-Boot.
 
 	  https://github.com/sbabic/libubootenv/
+
+comment "libubootenv application library needs a glibc or uClibc toolchain w/ dynamic library"
+	depends on BR2_STATIC_LIBS || BR2_TOOLCHAIN_USES_MUSL