diff mbox series

[2/2] package/libdrm: correct cunit test dependency

Message ID 1541098696-25824-2-git-send-email-matthew.weber@rockwellcollins.com
State Accepted
Headers show
Series [1/2] package/cunit: new package | expand

Commit Message

Matt Weber Nov. 1, 2018, 6:58 p.m. UTC
Previously the option to install tests would result in the test
cases that don't have a cunit dependency, to build and be installed.

This patch adds the cunit dependency so all test cases are built and
installed to target when that is selected via kconfig.

Signed-off-by: Matthew Weber <matthew.weber@rockwellcollins.com>
---
 package/libdrm/Config.in | 1 +
 package/libdrm/libdrm.mk | 3 +++
 2 files changed, 4 insertions(+)

Comments

Thomas Petazzoni Nov. 29, 2018, 9:54 p.m. UTC | #1
Hello,

On Thu,  1 Nov 2018 13:58:16 -0500, Matt Weber wrote:
> Previously the option to install tests would result in the test
> cases that don't have a cunit dependency, to build and be installed.
> 
> This patch adds the cunit dependency so all test cases are built and
> installed to target when that is selected via kconfig.

Looking at the libdrm build system, only the tests specific to  the
amdgpu backend/driver need cunit. So when you say "By default most of
the test cases will automatically be disabled if cunit is not present"
doesn't seem really accurate. So I've changed this patch to make cunit
an optional dependency: if it's there, we use it, otherwise, fine, we
have some tests, but not the amdgpu tests.

Did I miss something?

Anyway, I've applied the patch that adds it as an optional dependency
to the next branch.

Best regards,

Thomas
Matthew Weber Nov. 29, 2018, 10:19 p.m. UTC | #2
Thomas,


On Thu, Nov 29, 2018 at 3:55 PM Thomas Petazzoni
<thomas.petazzoni@bootlin.com> wrote:
>
> Hello,
>
> On Thu,  1 Nov 2018 13:58:16 -0500, Matt Weber wrote:
> > Previously the option to install tests would result in the test
> > cases that don't have a cunit dependency, to build and be installed.
> >
> > This patch adds the cunit dependency so all test cases are built and
> > installed to target when that is selected via kconfig.
>
> Looking at the libdrm build system, only the tests specific to  the
> amdgpu backend/driver need cunit. So when you say "By default most of
> the test cases will automatically be disabled if cunit is not present"
> doesn't seem really accurate. So I've changed this patch to make cunit
> an optional dependency: if it's there, we use it, otherwise, fine, we
> have some tests, but not the amdgpu tests.
>
> Did I miss something?

No, that should be ok.
diff mbox series

Patch

diff --git a/package/libdrm/Config.in b/package/libdrm/Config.in
index 581f921..9dd1fb7 100644
--- a/package/libdrm/Config.in
+++ b/package/libdrm/Config.in
@@ -99,6 +99,7 @@  config BR2_PACKAGE_LIBDRM_VC4
 
 config BR2_PACKAGE_LIBDRM_INSTALL_TESTS
 	bool "Install test programs"
+	select BR2_PACKAGE_CUNIT
 	help
 	  This option allows to install the libdrm test programs.
 
diff --git a/package/libdrm/libdrm.mk b/package/libdrm/libdrm.mk
index 18ef9cd..e927dd1 100644
--- a/package/libdrm/libdrm.mk
+++ b/package/libdrm/libdrm.mk
@@ -115,6 +115,9 @@  endif
 
 ifeq ($(BR2_PACKAGE_LIBDRM_INSTALL_TESTS),y)
 LIBDRM_CONF_OPTS += --enable-install-test-programs
+# By default most of the test cases with automatically
+# be disabled if cunit is not present
+LIBDRM_DEPENDENCIES += cunit
 endif
 
 $(eval $(autotools-package))