diff mbox

zmqpp: update license

Message ID 1489501777-6548-1-git-send-email-rahul.bedarkar@imgtec.com
State Accepted
Headers show

Commit Message

Rahul Bedarkar March 14, 2017, 2:29 p.m. UTC
Since version 4.1.2, zmqpp is provided under MPLv2.

Signed-off-by: Rahul Bedarkar <rahul.bedarkar@imgtec.com>
---
 package/zmqpp/zmqpp.mk | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comments

Thomas Petazzoni March 14, 2017, 8:59 p.m. UTC | #1
Hello,

On Tue, 14 Mar 2017 19:59:37 +0530, Rahul Bedarkar wrote:
> Since version 4.1.2, zmqpp is provided under MPLv2.
> 
> Signed-off-by: Rahul Bedarkar <rahul.bedarkar@imgtec.com>
> ---
>  package/zmqpp/zmqpp.mk | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)
> 
> diff --git a/package/zmqpp/zmqpp.mk b/package/zmqpp/zmqpp.mk
> index 18da709..3e35fd7 100644
> --- a/package/zmqpp/zmqpp.mk
> +++ b/package/zmqpp/zmqpp.mk
> @@ -8,7 +8,7 @@ ZMQPP_VERSION = 4.1.2
>  ZMQPP_SITE = $(call github,zeromq,zmqpp,$(ZMQPP_VERSION))
>  ZMQPP_INSTALL_STAGING = YES
>  ZMQPP_DEPENDENCIES = zeromq
> -ZMQPP_LICENSE = MIT
> +ZMQPP_LICENSE = MPLv2.0

Wow, thanks, well noticed indeed! Patch applied to master.

And the worst thing is that previous versions were not even under the
MIT license: they were under LGPLv3 + static linking exception.

Peter: we really want this one in the LTS branch, since 4.1.2 was
already used in the LTS branch.

Thanks a lot!

Thomas
Peter Korsgaard March 14, 2017, 10:05 p.m. UTC | #2
>>>>> "Thomas" == Thomas Petazzoni <thomas.petazzoni@free-electrons.com> writes:

 > Hello,
 > On Tue, 14 Mar 2017 19:59:37 +0530, Rahul Bedarkar wrote:
 >> Since version 4.1.2, zmqpp is provided under MPLv2.
 >> 
 >> Signed-off-by: Rahul Bedarkar <rahul.bedarkar@imgtec.com>
 >> ---
 >> package/zmqpp/zmqpp.mk | 2 +-
 >> 1 file changed, 1 insertion(+), 1 deletion(-)
 >> 
 >> diff --git a/package/zmqpp/zmqpp.mk b/package/zmqpp/zmqpp.mk
 >> index 18da709..3e35fd7 100644
 >> --- a/package/zmqpp/zmqpp.mk
 >> +++ b/package/zmqpp/zmqpp.mk
 >> @@ -8,7 +8,7 @@ ZMQPP_VERSION = 4.1.2
 >> ZMQPP_SITE = $(call github,zeromq,zmqpp,$(ZMQPP_VERSION))
 >> ZMQPP_INSTALL_STAGING = YES
 >> ZMQPP_DEPENDENCIES = zeromq
 >> -ZMQPP_LICENSE = MIT
 >> +ZMQPP_LICENSE = MPLv2.0

 > Wow, thanks, well noticed indeed! Patch applied to master.

 > And the worst thing is that previous versions were not even under the
 > MIT license: they were under LGPLv3 + static linking exception.

Gaah :/

 > Peter: we really want this one in the LTS branch, since 4.1.2 was
 > already used in the LTS branch.

Committed to 2017.02.x, thanks.
diff mbox

Patch

diff --git a/package/zmqpp/zmqpp.mk b/package/zmqpp/zmqpp.mk
index 18da709..3e35fd7 100644
--- a/package/zmqpp/zmqpp.mk
+++ b/package/zmqpp/zmqpp.mk
@@ -8,7 +8,7 @@  ZMQPP_VERSION = 4.1.2
 ZMQPP_SITE = $(call github,zeromq,zmqpp,$(ZMQPP_VERSION))
 ZMQPP_INSTALL_STAGING = YES
 ZMQPP_DEPENDENCIES = zeromq
-ZMQPP_LICENSE = MIT
+ZMQPP_LICENSE = MPLv2.0
 ZMQPP_LICENSE_FILES = LICENSE
 ZMQPP_MAKE_OPTS = LD="$(TARGET_CXX)" BUILD_PATH=./build PREFIX=/usr
 ZMQPP_LDFLAGS = $(TARGET_LDFLAGS) -lpthread