diff mbox

[1/1] package/qextserialport: remove the default value of the _INSTALL_STAGING variable

Message ID 1483717318-15930-1-git-send-email-jerzy.grzegorek@trzebnica.net
State Rejected
Headers show

Commit Message

Jerzy Grzegorek Jan. 6, 2017, 3:41 p.m. UTC
Signed-off-by: Jerzy Grzegorek <jerzy.grzegorek@trzebnica.net>
---
 package/qextserialport/qextserialport.mk | 4 +---
 1 file changed, 1 insertion(+), 3 deletions(-)

Comments

Peter Korsgaard Jan. 9, 2017, 8:53 a.m. UTC | #1
>>>>> "Jerzy" == Jerzy Grzegorek <jerzy.grzegorek@trzebnica.net> writes:

 > Signed-off-by: Jerzy Grzegorek <jerzy.grzegorek@trzebnica.net>
 > ---
 >  package/qextserialport/qextserialport.mk | 4 +---
 >  1 file changed, 1 insertion(+), 3 deletions(-)

 > diff --git a/package/qextserialport/qextserialport.mk b/package/qextserialport/qextserialport.mk
 > index 1100946..44ed6a3 100644
 > --- a/package/qextserialport/qextserialport.mk
 > +++ b/package/qextserialport/qextserialport.mk
 > @@ -34,9 +34,7 @@ define QEXTSERIALPORT_INSTALL_STAGING_CMDS
 >  	$(TARGET_MAKE_ENV) $(MAKE) -C $(@D) install
 >  endef
 
 > -ifeq ($(BR2_STATIC_LIBS),y)
 > -QEXTSERIALPORT_INSTALL_STAGING = NO
 > -else
 > +ifeq ($(BR2_STATIC_LIBS),)
 >  define QEXTSERIALPORT_INSTALL_TARGET_CMDS
 >  	cp -a $(@D)/*.so.* $(TARGET_DIR)/usr/lib
 >  endef

I believe this was just a typo and Arnout instead wanted to do
QEXTSERIALPORT_INSTALL_TARGET = NO. We haven't noticed as it is purely
cosmetical (as  QEXTSERIALPORT_INSTALL_TARGET_CMDS only gets defined for
!static).

I have instead pushed a commit changing it to
QEXTSERIALPORT_INSTALL_TARGET, thanks.
diff mbox

Patch

diff --git a/package/qextserialport/qextserialport.mk b/package/qextserialport/qextserialport.mk
index 1100946..44ed6a3 100644
--- a/package/qextserialport/qextserialport.mk
+++ b/package/qextserialport/qextserialport.mk
@@ -34,9 +34,7 @@  define QEXTSERIALPORT_INSTALL_STAGING_CMDS
 	$(TARGET_MAKE_ENV) $(MAKE) -C $(@D) install
 endef
 
-ifeq ($(BR2_STATIC_LIBS),y)
-QEXTSERIALPORT_INSTALL_STAGING = NO
-else
+ifeq ($(BR2_STATIC_LIBS),)
 define QEXTSERIALPORT_INSTALL_TARGET_CMDS
 	cp -a $(@D)/*.so.* $(TARGET_DIR)/usr/lib
 endef