diff mbox

[v3,2/2] package/php: set MySQL socket path

Message ID 1473804231-9767-2-git-send-email-bos@je-eigen-domein.nl
State Accepted
Headers show

Commit Message

Floris Bos Sept. 13, 2016, 10:03 p.m. UTC
Set the PHP default MySQL socket path to match what the
mysql package is using.

Signed-off-by: Floris Bos <bos@je-eigen-domein.nl>
---
 package/php/php.mk | 5 +++++
 1 file changed, 5 insertions(+)
diff mbox

Patch

diff --git a/package/php/php.mk b/package/php/php.mk
index 7df10be..1ea47f2 100644
--- a/package/php/php.mk
+++ b/package/php/php.mk
@@ -211,6 +211,11 @@  PHP_DEPENDENCIES += unixodbc
 endif
 endif
 
+ifneq ($(BR2_PACKAGE_PHP_EXT_MYSQLI)$(BR2_PACKAGE_PHP_EXT_PDO_MYSQL),)
+# Set default MySQL unix socket to what the MySQL server is using by default
+PHP_CONF_OPTS += --with-mysql-sock=$(MYSQL_SOCKET)
+endif
+
 define PHP_DISABLE_PCRE_JIT
 	$(SED) '/^#define SUPPORT_JIT/d' $(@D)/ext/pcre/pcrelib/config.h
 endef