diff mbox

[v2] libarchive: fix build error when linking with lzma

Message ID 1469110226-24349-1-git-send-email-sergio.prado@e-labworks.com
State Accepted
Headers show

Commit Message

Sergio Prado July 21, 2016, 2:10 p.m. UTC
Build fails when linking with liblzma compiled without threads support.

./.libs/libarchive.so: undefined reference to `lzma_cputhreads'
./.libs/libarchive.so: undefined reference to `lzma_stream_encoder_mt'

So let's enable LZMA only when toolchain has threads support.

Fixes:
http://autobuild.buildroot.org/results/2cb7f8a056982d0b894d0e2531ef357e74c8b796
http://autobuild.buildroot.org/results/d12954fbd460d396f255158fa127f39ff9d2be8d
http://autobuild.buildroot.org/results/abe10c70f38423a212ab27d7d27e22174eaa5aab
Many more...

Signed-off-by: Sergio Prado <sergio.prado@e-labworks.com>

---
Changes v1 -> v2:
  - removing extra comma from evaluation
---
 package/libarchive/libarchive.mk | 3 ++-
 1 file changed, 2 insertions(+), 1 deletion(-)

Comments

Thomas Petazzoni July 23, 2016, 1:55 p.m. UTC | #1
Hello,

On Thu, 21 Jul 2016 11:10:26 -0300, Sergio Prado wrote:
> Build fails when linking with liblzma compiled without threads support.
> 
> ./.libs/libarchive.so: undefined reference to `lzma_cputhreads'
> ./.libs/libarchive.so: undefined reference to `lzma_stream_encoder_mt'
> 
> So let's enable LZMA only when toolchain has threads support.
> 
> Fixes:
> http://autobuild.buildroot.org/results/2cb7f8a056982d0b894d0e2531ef357e74c8b796
> http://autobuild.buildroot.org/results/d12954fbd460d396f255158fa127f39ff9d2be8d
> http://autobuild.buildroot.org/results/abe10c70f38423a212ab27d7d27e22174eaa5aab
> Many more...
> 
> Signed-off-by: Sergio Prado <sergio.prado@e-labworks.com>
> 
> ---
> Changes v1 -> v2:
>   - removing extra comma from evaluation
> ---
>  package/libarchive/libarchive.mk | 3 ++-
>  1 file changed, 2 insertions(+), 1 deletion(-)

Applied to master, thanks.

Thomas
diff mbox

Patch

diff --git a/package/libarchive/libarchive.mk b/package/libarchive/libarchive.mk
index 6e9c0a1e867b..30a231885a71 100644
--- a/package/libarchive/libarchive.mk
+++ b/package/libarchive/libarchive.mk
@@ -92,7 +92,8 @@  else
 LIBARCHIVE_CONF_OPTS += --without-zlib
 endif
 
-ifeq ($(BR2_PACKAGE_XZ),y)
+# libarchive requires LZMA with thread support in the toolchain
+ifeq ($(BR2_TOOLCHAIN_HAS_THREADS)$(BR2_PACKAGE_XZ),yy)
 LIBARCHIVE_DEPENDENCIES += xz
 LIBARCHIVE_CONF_OPTS += --with-lzma
 else