diff mbox

[02/32] package/systemd: remove BR2_PACKAGE_SYSTEMD_ALL_EXTRAS

Message ID 1456437341-19025-3-git-send-email-gabe@hashrabbit.co
State Accepted
Headers show

Commit Message

Gabe Evans Feb. 25, 2016, 9:55 p.m. UTC
The option was a bit misleading since it only selected additional
libraries without --enable/disabling any features. Including all of them
here would add a lot of bloat so instead, it is replaced with notes
detailing which features each library enables.

Signed-off-by: Gabe Evans <gabe@hashrabbit.co>
---
 package/systemd/Config.in  | 11 +++--------
 package/systemd/systemd.mk | 16 ++++++++++------
 2 files changed, 13 insertions(+), 14 deletions(-)

Comments

Arnout Vandecappelle Feb. 25, 2016, 11:52 p.m. UTC | #1
On 02/25/16 22:55, Gabe Evans wrote:
> The option was a bit misleading since it only selected additional
> libraries without --enable/disabling any features. Including all of them
> here would add a lot of bloat so instead, it is replaced with notes
> detailing which features each library enables.
> 
> Signed-off-by: Gabe Evans <gabe@hashrabbit.co>
> ---
>  package/systemd/Config.in  | 11 +++--------
>  package/systemd/systemd.mk | 16 ++++++++++------
>  2 files changed, 13 insertions(+), 14 deletions(-)
> 
> diff --git a/package/systemd/Config.in b/package/systemd/Config.in
> index f7fc3bb..1972b1d 100644
> --- a/package/systemd/Config.in
> +++ b/package/systemd/Config.in
> @@ -56,6 +56,9 @@ config BR2_PACKAGE_SYSTEMD
>  	  The selection of other packages will enable some features:
>  
>  	  - acl package will add support for multi-seat.
> +	  - xz package will add compression support in journal and coredump.
> +	  - libgcrypt package will add support for journal sealing and resolved
> +	    DNSSEC verification.

 Line is too long. Also 'resolved' is a bit weird here, so:

	  - libgcrypt package will add support for journal sealing and
	    DNSSEC verification in resolved

>  
>  	  http://freedesktop.org/wiki/Software/systemd
>  
> @@ -64,14 +67,6 @@ if BR2_PACKAGE_SYSTEMD
>  config BR2_PACKAGE_PROVIDES_UDEV
>  	default "systemd"
>  
> -config BR2_PACKAGE_SYSTEMD_ALL_EXTRAS

 You'll need to move this to Config.in.legacy, keep the two select statements
below, and add a help text explaining that the option has been removed and that
xz and libgcrypt have to be selected manually in the future.


 Regards,
 Arnout


> -	bool "enable all extras"
> -	select BR2_PACKAGE_XZ
> -	select BR2_PACKAGE_LIBGCRYPT
> -	help
> -	  Enable extra features for Systemd: journal compression and
> -	  signing.
> -
>  config BR2_PACKAGE_SYSTEMD_KDBUS
>  	bool "enable kdbus support"
>  	help
> diff --git a/package/systemd/systemd.mk b/package/systemd/systemd.mk
> index 05121cf..7a1baf5 100644
> --- a/package/systemd/systemd.mk
> +++ b/package/systemd/systemd.mk
> @@ -76,16 +76,20 @@ else
>  SYSTEMD_CONF_OPTS += --disable-kdbus
>  endif
>  
> -ifeq ($(BR2_PACKAGE_SYSTEMD_ALL_EXTRAS),y)
> -SYSTEMD_DEPENDENCIES += xz libgcrypt
> +ifeq ($(BR2_PACKAGE_XZ),y)
> +SYSTEMD_DEPENDENCIES += xz
> +SYSTEMD_CONF_OPTS += --enable-xz
> +else
> +SYSTEMD_CONF_OPTS += --disable-xz
> +endif
> +
> +ifeq ($(BR2_PACKAGE_LIBGCRYPT),y)
> +SYSTEMD_DEPENDENCIES += libgcrypt
>  SYSTEMD_CONF_OPTS += \
> -	--enable-xz \
>  	--enable-gcrypt	\
>  	--with-libgcrypt-prefix=$(STAGING_DIR)/usr
>  else
> -SYSTEMD_CONF_OPTS += \
> -	--disable-xz \
> -	--disable-gcrypt
> +SYSTEMD_CONF_OPTS += --disable-gcrypt
>  endif
>  
>  ifeq ($(BR2_PACKAGE_SYSTEMD_JOURNAL_GATEWAY),y)
>
Thomas Petazzoni Feb. 29, 2016, 9:44 p.m. UTC | #2
Dear Gabe Evans,

On Thu, 25 Feb 2016 21:55:11 +0000, Gabe Evans wrote:
> The option was a bit misleading since it only selected additional
> libraries without --enable/disabling any features. Including all of them
> here would add a lot of bloat so instead, it is replaced with notes
> detailing which features each library enables.
> 
> Signed-off-by: Gabe Evans <gabe@hashrabbit.co>
> ---
>  package/systemd/Config.in  | 11 +++--------
>  package/systemd/systemd.mk | 16 ++++++++++------
>  2 files changed, 13 insertions(+), 14 deletions(-)

Applied to next with the following changes:

    [Thomas:
     - slightly tweak Config.in help text, as suggested by Arnout.
     - add Config.in.legacy handling for BR2_PACKAGE_SYSTEMD_ALL_EXTRAS,
       as suggested by Arnout.]

Thanks!

Thomas
diff mbox

Patch

diff --git a/package/systemd/Config.in b/package/systemd/Config.in
index f7fc3bb..1972b1d 100644
--- a/package/systemd/Config.in
+++ b/package/systemd/Config.in
@@ -56,6 +56,9 @@  config BR2_PACKAGE_SYSTEMD
 	  The selection of other packages will enable some features:
 
 	  - acl package will add support for multi-seat.
+	  - xz package will add compression support in journal and coredump.
+	  - libgcrypt package will add support for journal sealing and resolved
+	    DNSSEC verification.
 
 	  http://freedesktop.org/wiki/Software/systemd
 
@@ -64,14 +67,6 @@  if BR2_PACKAGE_SYSTEMD
 config BR2_PACKAGE_PROVIDES_UDEV
 	default "systemd"
 
-config BR2_PACKAGE_SYSTEMD_ALL_EXTRAS
-	bool "enable all extras"
-	select BR2_PACKAGE_XZ
-	select BR2_PACKAGE_LIBGCRYPT
-	help
-	  Enable extra features for Systemd: journal compression and
-	  signing.
-
 config BR2_PACKAGE_SYSTEMD_KDBUS
 	bool "enable kdbus support"
 	help
diff --git a/package/systemd/systemd.mk b/package/systemd/systemd.mk
index 05121cf..7a1baf5 100644
--- a/package/systemd/systemd.mk
+++ b/package/systemd/systemd.mk
@@ -76,16 +76,20 @@  else
 SYSTEMD_CONF_OPTS += --disable-kdbus
 endif
 
-ifeq ($(BR2_PACKAGE_SYSTEMD_ALL_EXTRAS),y)
-SYSTEMD_DEPENDENCIES += xz libgcrypt
+ifeq ($(BR2_PACKAGE_XZ),y)
+SYSTEMD_DEPENDENCIES += xz
+SYSTEMD_CONF_OPTS += --enable-xz
+else
+SYSTEMD_CONF_OPTS += --disable-xz
+endif
+
+ifeq ($(BR2_PACKAGE_LIBGCRYPT),y)
+SYSTEMD_DEPENDENCIES += libgcrypt
 SYSTEMD_CONF_OPTS += \
-	--enable-xz \
 	--enable-gcrypt	\
 	--with-libgcrypt-prefix=$(STAGING_DIR)/usr
 else
-SYSTEMD_CONF_OPTS += \
-	--disable-xz \
-	--disable-gcrypt
+SYSTEMD_CONF_OPTS += --disable-gcrypt
 endif
 
 ifeq ($(BR2_PACKAGE_SYSTEMD_JOURNAL_GATEWAY),y)