diff mbox

[v2,02/18] pkg-rebar.mk: pass C++ compiler path and options

Message ID 1454443064-14269-3-git-send-email-fhunleth@troodon-software.com
State Accepted
Headers show

Commit Message

Frank Hunleth Feb. 2, 2016, 7:57 p.m. UTC
Previously only the C compiler path and options were passed to rebar.
Erlang projects that used the C++ compiler would fail to build. This
fixes those errors.

Signed-off-by: Frank Hunleth <fhunleth@troodon-software.com>
---
 package/pkg-rebar.mk | 2 ++
 1 file changed, 2 insertions(+)

Comments

Romain Naour Feb. 6, 2016, 10:34 p.m. UTC | #1
Hi Frank, All,

Le 02/02/2016 20:57, Frank Hunleth a écrit :
> Previously only the C compiler path and options were passed to rebar.
> Erlang projects that used the C++ compiler would fail to build. This
> fixes those errors.
> 
> Signed-off-by: Frank Hunleth <fhunleth@troodon-software.com>

C++ support is currently only required for erlang-p1-stringprep, right ?

Reviewed-by: Romain Naour <romain.naour@gmail.com>

Best regards,
Romain

> ---
>  package/pkg-rebar.mk | 2 ++
>  1 file changed, 2 insertions(+)
> 
> diff --git a/package/pkg-rebar.mk b/package/pkg-rebar.mk
> index c727489..44c6d6c 100644
> --- a/package/pkg-rebar.mk
> +++ b/package/pkg-rebar.mk
> @@ -158,7 +158,9 @@ ifndef $(2)_BUILD_CMDS
>  define $(2)_BUILD_CMDS
>  	(cd $$(@D); \
>  		CC="$$(TARGET_CC)" \
> +		CXX="$$(TARGET_CXX)" \
>  		CFLAGS="$$(TARGET_CFLAGS)" \
> +		CXXFLAGS="$$(TARGET_CXXFLAGS)" \
>  		LDFLAGS="$$(TARGET_LDFLAGS)" \
>  		$$(REBAR_TARGET_DEPS_ENV) \
>  		$$(TARGET_MAKE_ENV) \
>
Frank Hunleth Feb. 9, 2016, 1:45 a.m. UTC | #2
Hi Romain,

On Sat, Feb 6, 2016 at 5:34 PM, Romain Naour <romain.naour@gmail.com> wrote:
> Hi Frank, All,
>
> Le 02/02/2016 20:57, Frank Hunleth a écrit :
>> Previously only the C compiler path and options were passed to rebar.
>> Erlang projects that used the C++ compiler would fail to build. This
>> fixes those errors.
>>
>> Signed-off-by: Frank Hunleth <fhunleth@troodon-software.com>
>
> C++ support is currently only required for erlang-p1-stringprep, right ?

Yes, that is the only one. I'll add this to the comment in the next version.

>
> Reviewed-by: Romain Naour <romain.naour@gmail.com>
>
> Best regards,
> Romain
>
>> ---
>>  package/pkg-rebar.mk | 2 ++
>>  1 file changed, 2 insertions(+)
>>
>> diff --git a/package/pkg-rebar.mk b/package/pkg-rebar.mk
>> index c727489..44c6d6c 100644
>> --- a/package/pkg-rebar.mk
>> +++ b/package/pkg-rebar.mk
>> @@ -158,7 +158,9 @@ ifndef $(2)_BUILD_CMDS
>>  define $(2)_BUILD_CMDS
>>       (cd $$(@D); \
>>               CC="$$(TARGET_CC)" \
>> +             CXX="$$(TARGET_CXX)" \
>>               CFLAGS="$$(TARGET_CFLAGS)" \
>> +             CXXFLAGS="$$(TARGET_CXXFLAGS)" \
>>               LDFLAGS="$$(TARGET_LDFLAGS)" \
>>               $$(REBAR_TARGET_DEPS_ENV) \
>>               $$(TARGET_MAKE_ENV) \
>>
Thomas Petazzoni Feb. 20, 2016, 6:23 p.m. UTC | #3
Dear Frank Hunleth,

On Tue,  2 Feb 2016 14:57:28 -0500, Frank Hunleth wrote:
> Previously only the C compiler path and options were passed to rebar.
> Erlang projects that used the C++ compiler would fail to build. This
> fixes those errors.
> 
> Signed-off-by: Frank Hunleth <fhunleth@troodon-software.com>
> ---
>  package/pkg-rebar.mk | 2 ++
>  1 file changed, 2 insertions(+)

I've added the information suggested by Romain Naour in the commit log,
i.e the package that first needed the C++ support. And then I've
applied to the next branch. Thanks!

Thomas
diff mbox

Patch

diff --git a/package/pkg-rebar.mk b/package/pkg-rebar.mk
index c727489..44c6d6c 100644
--- a/package/pkg-rebar.mk
+++ b/package/pkg-rebar.mk
@@ -158,7 +158,9 @@  ifndef $(2)_BUILD_CMDS
 define $(2)_BUILD_CMDS
 	(cd $$(@D); \
 		CC="$$(TARGET_CC)" \
+		CXX="$$(TARGET_CXX)" \
 		CFLAGS="$$(TARGET_CFLAGS)" \
+		CXXFLAGS="$$(TARGET_CXXFLAGS)" \
 		LDFLAGS="$$(TARGET_LDFLAGS)" \
 		$$(REBAR_TARGET_DEPS_ENV) \
 		$$(TARGET_MAKE_ENV) \