diff mbox

pv: fix build error on sparc/sparc64

Message ID 1452027708-22658-1-git-send-email-sergio.prado@e-labworks.com
State Accepted
Commit 4ed37b14bc1160b0ddbbb1590bbd604bfae63563
Headers show

Commit Message

Sergio Prado Jan. 5, 2016, 9:01 p.m. UTC
Relax linker option is enabled by default on sparc/sparc64
architectures, and it can't be used together with -r option, so disabled
it.

Fixes:
http://autobuild.buildroot.net/results/fadc6fc5500d68b91aead58b1d74887db5244f52/
http://autobuild.buildroot.net/results/2f30486f2d72e0277fc30febd4012825a59e4f41/
http://autobuild.buildroot.net/results/82ccb8f0818d1909309eaef969548f963fc6cf04/
...

Signed-off-by: Sergio Prado <sergio.prado@e-labworks.com>
---
 package/pv/pv.mk | 9 ++++++++-
 1 file changed, 8 insertions(+), 1 deletion(-)

Comments

Peter Korsgaard Jan. 5, 2016, 9:41 p.m. UTC | #1
>>>>> "Sergio" == Sergio Prado <sergio.prado@e-labworks.com> writes:

 > Relax linker option is enabled by default on sparc/sparc64
 > architectures, and it can't be used together with -r option, so disabled
 > it.

 > Fixes:
 > http://autobuild.buildroot.net/results/fadc6fc5500d68b91aead58b1d74887db5244f52/
 > http://autobuild.buildroot.net/results/2f30486f2d72e0277fc30febd4012825a59e4f41/
 > http://autobuild.buildroot.net/results/82ccb8f0818d1909309eaef969548f963fc6cf04/
 > ...

 > Signed-off-by: Sergio Prado <sergio.prado@e-labworks.com>
 > ---
 >  package/pv/pv.mk | 9 ++++++++-
 >  1 file changed, 8 insertions(+), 1 deletion(-)

 > diff --git a/package/pv/pv.mk b/package/pv/pv.mk
 > index 5346b10fc49f..80c1ec349ba7 100644
 > --- a/package/pv/pv.mk
 > +++ b/package/pv/pv.mk
 > @@ -17,6 +17,13 @@ PV_LICENSE_FILES = doc/COPYING
 >  # ensuring that host-gettext is built if gettext support is enabled;
 >  PV_DEPENDENCIES = $(if $(BR2_NEEDS_GETTEXT_IF_LOCALE),gettext host-gettext)
 
 > +# --relax linker option is enabled by default on sparc/sparc64
 > +# architectures, and it can't be used together with -r option, so
 > +# disabled it.

s/disabled/disable/ (here and in the commit message).

Committed with that fixed, thanks.
diff mbox

Patch

diff --git a/package/pv/pv.mk b/package/pv/pv.mk
index 5346b10fc49f..80c1ec349ba7 100644
--- a/package/pv/pv.mk
+++ b/package/pv/pv.mk
@@ -17,6 +17,13 @@  PV_LICENSE_FILES = doc/COPYING
 # ensuring that host-gettext is built if gettext support is enabled;
 PV_DEPENDENCIES = $(if $(BR2_NEEDS_GETTEXT_IF_LOCALE),gettext host-gettext)
 
+# --relax linker option is enabled by default on sparc/sparc64
+# architectures, and it can't be used together with -r option, so
+# disabled it.
+ifeq ($(BR2_sparc)$(BR2_sparc64),y)
+PV_LDFLAGS = "-Wl,--no-relax"
+endif
+
 # While 'pv' uses autoconf, it does not use automake for its
 # makefiles. It uses $(LD) $(LDFLAGS) to achieve partial linking, but
 # using 'ld' directly doesn't work well with some toolchain
@@ -25,6 +32,6 @@  PV_DEPENDENCIES = $(if $(BR2_NEEDS_GETTEXT_IF_LOCALE),gettext host-gettext)
 # ensure that 'gcc' is used to do these partial linking steps.
 PV_MAKE_OPTS = \
 	LD="$(TARGET_CC)" \
-	LDFLAGS="-Wl,-r -nostdlib"
+	LDFLAGS="-Wl,-r -nostdlib $(PV_LDFLAGS)"
 
 $(eval $(autotools-package))