diff mbox

[PATCHv3,1/3] micropython: Invert fallback detection logic

Message ID 1443051831-8292-2-git-send-email-judge.packham@gmail.com
State Accepted
Commit 4d061220ae85e8f4cae2ebc490f687385e40a677
Headers show

Commit Message

Chris Packham Sept. 23, 2015, 11:43 p.m. UTC
Rather than specifying architectures that do not have explicit support
in micropython invert the logic and set MICROPY_GCREGS_SETJMP=1 if the
architecture does not have explicit support. MIPS is listed as being
supported but this support consists of automatically defining
MICROPY_GCREGS_SETJMP 1 based on __mips__ being defined.

Signed-off-by: Chris Packham <judge.packham@gmail.com>
---
This should clean up most of the remaining build failures. Listing the
architectures with explicit support makes more sense to me and is
certainly a shorter list at the moment.
    
Changes since v1:
- Use positive logic ifeq(,) instead of ifneq(,y)
Changes since v2:
- none

 package/micropython/micropython.mk | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
diff mbox

Patch

diff --git a/package/micropython/micropython.mk b/package/micropython/micropython.mk
index 7ae88a0..1358864 100644
--- a/package/micropython/micropython.mk
+++ b/package/micropython/micropython.mk
@@ -15,7 +15,7 @@  MICROPYTHON_PATCH = \
 
 # Use fallback implementation for exception handling on architectures that don't
 # have explicit support.
-ifeq ($(BR2_powerpc)$(BR2_sh)$(BR2_xtensa),y)
+ifeq ($(BR2_i386)$(BR2_x86_64)$(BR2_arm)$(BR2_armeb),)
 MICROPYTHON_CFLAGS = -DMICROPY_GCREGS_SETJMP=1
 endif