diff mbox

[1/6] php: delete /usr/lib/php/build instead of /usr/lib/php

Message ID 1431978724-25081-1-git-send-email-bos@je-eigen-domein.nl
State Accepted
Commit ec0404a9a426e866dff20bf11b33c06b90f9f85d
Headers show

Commit Message

Floris Bos May 18, 2015, 7:51 p.m. UTC
External PHP modules like the OPcache may live in
/usr/lib/php/extensions, so only delete /usr/lib/php/build

Signed-off-by: Floris Bos <bos@je-eigen-domein.nl>
---
 package/php/php.mk | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comments

Thomas Petazzoni May 18, 2015, 8:32 p.m. UTC | #1
Dear Floris Bos,

On Mon, 18 May 2015 21:51:59 +0200, Floris Bos wrote:
> External PHP modules like the OPcache may live in
> /usr/lib/php/extensions, so only delete /usr/lib/php/build
> 
> Signed-off-by: Floris Bos <bos@je-eigen-domein.nl>
> ---
>  package/php/php.mk | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)

This patch fixes bug #8121,
https://bugs.busybox.net/show_bug.cgi?id=8121.

Thomas
Peter Korsgaard May 19, 2015, 7:38 p.m. UTC | #2
>>>>> "Floris" == Floris Bos <bos@je-eigen-domein.nl> writes:

 > External PHP modules like the OPcache may live in
 > /usr/lib/php/extensions, so only delete /usr/lib/php/build

 > Signed-off-by: Floris Bos <bos@je-eigen-domein.nl>

Committed, thanks.
diff mbox

Patch

diff --git a/package/php/php.mk b/package/php/php.mk
index 47811ff..c36a80c 100644
--- a/package/php/php.mk
+++ b/package/php/php.mk
@@ -290,7 +290,7 @@  endef
 PHP_POST_INSTALL_TARGET_HOOKS += PHP_EXTENSIONS_FIXUP
 
 define PHP_INSTALL_FIXUP
-	rm -rf $(TARGET_DIR)/usr/lib/php
+	rm -rf $(TARGET_DIR)/usr/lib/php/build
 	rm -f $(TARGET_DIR)/usr/bin/phpize
 	$(INSTALL) -D -m 0755 $(PHP_DIR)/php.ini-production \
 		$(TARGET_DIR)/etc/php.ini