diff mbox

[v2,1/1] package/boost: bump to version 1.58.0

Message ID 1430482091-8140-1-git-send-email-joerg.krause@embedded.rocks
State Changes Requested
Headers show

Commit Message

Jörg Krause May 1, 2015, 12:08 p.m. UTC
Add upstream patch from [1] to fix autobuild error [2] for mips:
	mipsel-linux-g++: error: unrecognized command line option '-m32'

[1] https://github.com/boostorg/build/commit/c0634341d9ee2c02d3a55c91dafb988afc066c49
[2] http://autobuild.buildroot.org/results/66c/66c3a868816dfe4bd4d0ffafec6988fd87a2c058/

Signed-off-by: Jörg Krause <joerg.krause@embedded.rocks>
---
Changes v1 -> v2:
  - Add upstream patch
---
 package/boost/0002-gcc-jam-mips1-fix.patch | 24 ++++++++++++++++++++++++
 package/boost/boost.hash                   |  6 +++---
 package/boost/boost.mk                     |  2 +-
 3 files changed, 28 insertions(+), 4 deletions(-)
 create mode 100644 package/boost/0002-gcc-jam-mips1-fix.patch

Comments

Gustavo Zacarias May 1, 2015, 12:32 p.m. UTC | #1
On 05/01/2015 09:08 AM, Jörg Krause wrote:

> Add upstream patch from [1] to fix autobuild error [2] for mips:
> 	mipsel-linux-g++: error: unrecognized command line option '-m32'
> 
> [1] https://github.com/boostorg/build/commit/c0634341d9ee2c02d3a55c91dafb988afc066c49
> [2] http://autobuild.buildroot.org/results/66c/66c3a868816dfe4bd4d0ffafec6988fd87a2c058/
> 
> Signed-off-by: Jörg Krause <joerg.krause@embedded.rocks>

Hi.
It will need some extra tweaking since it failed in a similar way for sh4:
http://autobuild.buildroot.net/results/ccd/ccd5c83963032ba49b1627b1dff39e34a9486943/build-end.log

Regards.
Thomas Petazzoni May 1, 2015, 2:29 p.m. UTC | #2
Dear Gustavo Zacarias,

On Fri, 01 May 2015 09:32:36 -0300, Gustavo Zacarias wrote:
> On 05/01/2015 09:08 AM, Jörg Krause wrote:
> 
> > Add upstream patch from [1] to fix autobuild error [2] for mips:
> > 	mipsel-linux-g++: error: unrecognized command line option '-m32'
> > 
> > [1] https://github.com/boostorg/build/commit/c0634341d9ee2c02d3a55c91dafb988afc066c49
> > [2] http://autobuild.buildroot.org/results/66c/66c3a868816dfe4bd4d0ffafec6988fd87a2c058/
> > 
> > Signed-off-by: Jörg Krause <joerg.krause@embedded.rocks>
> 
> Hi.
> It will need some extra tweaking since it failed in a similar way for sh4:
> http://autobuild.buildroot.net/results/ccd/ccd5c83963032ba49b1627b1dff39e34a9486943/build-end.log

Generally speaking, doing:

if $(arch) != arm && $(arch) != mips1

to decide whether to use -m32 is going to cause numerous problems. It
should be an opt-in test rather than an opt-out test. I.e only those
architectures that actually need -m32 should use it, rather than trying
to exclude all architectures that do not provide -m32.

Best regards,

Thomas
Gustavo Zacarias May 2, 2015, 1:15 p.m. UTC | #3
On 05/01/2015 11:29 AM, Thomas Petazzoni wrote:

>> Hi.
>> It will need some extra tweaking since it failed in a similar way for sh4:
>> http://autobuild.buildroot.net/results/ccd/ccd5c83963032ba49b1627b1dff39e34a9486943/build-end.log
> 
> Generally speaking, doing:
> 
> if $(arch) != arm && $(arch) != mips1
> 
> to decide whether to use -m32 is going to cause numerous problems. It
> should be an opt-in test rather than an opt-out test. I.e only those
> architectures that actually need -m32 should use it, rather than trying
> to exclude all architectures that do not provide -m32.

Actually on second thought they shouldn't even do that, that's compiler
setup and it's up to packaging to care care of it, via CFLAGS.
Regards.
diff mbox

Patch

diff --git a/package/boost/0002-gcc-jam-mips1-fix.patch b/package/boost/0002-gcc-jam-mips1-fix.patch
new file mode 100644
index 0000000..276626c
--- /dev/null
+++ b/package/boost/0002-gcc-jam-mips1-fix.patch
@@ -0,0 +1,24 @@ 
+package/boost: gcc.jam mips1 fix
+
+gcc.jam was passing the options -m32 and -m64 to mips cross-compilers, when
+those do not use such options. This modification solves it by adding mips as
+an exception.
+
+Fixes autobuild error:
+http://autobuild.buildroot.org/results/66c/66c3a868816dfe4bd4d0ffafec6988fd87a2c058
+
+Signed-off-by: Carlos M. Ferreira carlosmf.pt@gmail.com
+Signed-off-by: Jörg Krause <joerg.krause@embedded.rocks>
+Backported-from: c0634341d9ee2c02d3a55c91dafb988afc066c49
+
+--- boost_1_58_0/tools/build/src/tools/gcc.jam 2015-04-23 12:01:37.723438995 +0200
++++ boost_1_58_0/tools/build/src/tools/gcc.jam 2015-04-23 12:00:21.427441384 +0200
+@@ -451,7 +451,7 @@
+         else
+         {
+             local arch = [ feature.get-values architecture : $(properties) ] ;
+-            if $(arch) != arm
++            if $(arch) != arm && $(arch) != mips1
+             {
+                 if $(model) = 32
+                 {
diff --git a/package/boost/boost.hash b/package/boost/boost.hash
index 2019743..706eea2 100644
--- a/package/boost/boost.hash
+++ b/package/boost/boost.hash
@@ -1,3 +1,3 @@ 
-# From http://sourceforge.net/projects/boost/files/boost/1.57.0/
-md5	1be49befbdd9a5ce9def2983ba3e7b76	boost_1_57_0.tar.bz2
-sha1	e151557ae47afd1b43dc3fac46f8b04a8fe51c12	boost_1_57_0.tar.bz2
+# From http://sourceforge.net/projects/boost/files/boost/1.58.0/
+md5	b8839650e61e9c1c0a89f371dd475546	boost_1_58_0.tar.bz2
+sha1	2fc96c1651ac6fe9859b678b165bd78dc211e881	boost_1_58_0.tar.bz2
diff --git a/package/boost/boost.mk b/package/boost/boost.mk
index 7060591..c658628 100644
--- a/package/boost/boost.mk
+++ b/package/boost/boost.mk
@@ -4,7 +4,7 @@ 
 #
 ################################################################################
 
-BOOST_VERSION = 1.57.0
+BOOST_VERSION = 1.58.0
 BOOST_SOURCE = boost_$(subst .,_,$(BOOST_VERSION)).tar.bz2
 BOOST_SITE = http://downloads.sourceforge.net/project/boost/boost/$(BOOST_VERSION)
 BOOST_INSTALL_STAGING = YES