diff mbox

[v2,3/5] busybox: add option to specify config fragments

Message ID 1430231675-8613-3-git-send-email-bos@je-eigen-domein.nl
State Accepted
Headers show

Commit Message

Floris Bos April 28, 2015, 2:34 p.m. UTC
Signed-off-by: Floris Bos <bos@je-eigen-domein.nl>
---
 package/busybox/Config.in  | 6 ++++++
 package/busybox/busybox.mk | 1 +
 2 files changed, 7 insertions(+)

Comments

Arnout Vandecappelle May 2, 2015, 12:47 p.m. UTC | #1
On 28/04/15 16:34, Floris Bos wrote:
> Signed-off-by: Floris Bos <bos@je-eigen-domein.nl>

Acked-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>

 Not tested but obviously correct :-)

 Regards,
 Arnout

> ---
>  package/busybox/Config.in  | 6 ++++++
>  package/busybox/busybox.mk | 1 +
>  2 files changed, 7 insertions(+)
> 
> diff --git a/package/busybox/Config.in b/package/busybox/Config.in
> index b4f949f..6847a60 100644
> --- a/package/busybox/Config.in
> +++ b/package/busybox/Config.in
> @@ -20,6 +20,12 @@ config BR2_PACKAGE_BUSYBOX_CONFIG
>  
>  	  Most people will just use the default BusyBox configuration file.
>  
> +config BR2_PACKAGE_BUSYBOX_CONFIG_FRAGMENT_FILES
> +	string "Additional BusyBox configuration fragment files"
> +	help
> +	  A space-separated list of configuration fragment files,
> +	  that will be merged to the main BusyBox configuration file.
> +
>  config BR2_PACKAGE_BUSYBOX_SHOW_OTHERS
>  	bool "Show packages that are also provided by busybox"
>  	help
> diff --git a/package/busybox/busybox.mk b/package/busybox/busybox.mk
> index 1ce508a..090e174 100644
> --- a/package/busybox/busybox.mk
> +++ b/package/busybox/busybox.mk
> @@ -46,6 +46,7 @@ ifndef BUSYBOX_CONFIG_FILE
>  endif
>  
>  BUSYBOX_KCONFIG_FILE = $(BUSYBOX_CONFIG_FILE)
> +BUSYBOX_KCONFIG_FRAGMENT_FILES = $(call qstrip,$(BR2_PACKAGE_BUSYBOX_CONFIG_FRAGMENT_FILES))
>  BUSYBOX_KCONFIG_EDITORS = menuconfig xconfig gconfig
>  BUSYBOX_KCONFIG_OPTS = $(BUSYBOX_MAKE_OPTS)
>  
>
diff mbox

Patch

diff --git a/package/busybox/Config.in b/package/busybox/Config.in
index b4f949f..6847a60 100644
--- a/package/busybox/Config.in
+++ b/package/busybox/Config.in
@@ -20,6 +20,12 @@  config BR2_PACKAGE_BUSYBOX_CONFIG
 
 	  Most people will just use the default BusyBox configuration file.
 
+config BR2_PACKAGE_BUSYBOX_CONFIG_FRAGMENT_FILES
+	string "Additional BusyBox configuration fragment files"
+	help
+	  A space-separated list of configuration fragment files,
+	  that will be merged to the main BusyBox configuration file.
+
 config BR2_PACKAGE_BUSYBOX_SHOW_OTHERS
 	bool "Show packages that are also provided by busybox"
 	help
diff --git a/package/busybox/busybox.mk b/package/busybox/busybox.mk
index 1ce508a..090e174 100644
--- a/package/busybox/busybox.mk
+++ b/package/busybox/busybox.mk
@@ -46,6 +46,7 @@  ifndef BUSYBOX_CONFIG_FILE
 endif
 
 BUSYBOX_KCONFIG_FILE = $(BUSYBOX_CONFIG_FILE)
+BUSYBOX_KCONFIG_FRAGMENT_FILES = $(call qstrip,$(BR2_PACKAGE_BUSYBOX_CONFIG_FRAGMENT_FILES))
 BUSYBOX_KCONFIG_EDITORS = menuconfig xconfig gconfig
 BUSYBOX_KCONFIG_OPTS = $(BUSYBOX_MAKE_OPTS)