diff mbox

[v2,08/25] openssh: move systemd service files to /usr/lib

Message ID 1426878856-15747-9-git-send-email-mike@mikebwilliams.com
State Accepted
Headers show

Commit Message

Mike Williams March 20, 2015, 7:13 p.m. UTC
Signed-off-by: Mike Williams <mike@mikebwilliams.com>
---
 package/openssh/openssh.mk | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)
diff mbox

Patch

diff --git a/package/openssh/openssh.mk b/package/openssh/openssh.mk
index 08f3fa0..24af079 100644
--- a/package/openssh/openssh.mk
+++ b/package/openssh/openssh.mk
@@ -36,9 +36,9 @@  endif
 
 define OPENSSH_INSTALL_INIT_SYSTEMD
 	$(INSTALL) -D -m 644 package/openssh/sshd.service \
-		$(TARGET_DIR)/etc/systemd/system/sshd.service
+		$(TARGET_DIR)/usr/lib/systemd/system/sshd.service
 	mkdir -p $(TARGET_DIR)/etc/systemd/system/multi-user.target.wants
-	ln -fs ../sshd.service \
+	ln -fs ../../../../usr/lib/systemd/system/sshd.service \
 		$(TARGET_DIR)/etc/systemd/system/multi-user.target.wants/sshd.service
 endef