diff mbox

[6/7] package/efl/libevas: add optional dependency libfribidi

Message ID 1425028764-1146-7-git-send-email-fabio.porcedda@gmail.com
State Accepted
Commit a74ed49f661caebd51378b9ed9840be50b20ffdd
Headers show

Commit Message

Fabio Porcedda Feb. 27, 2015, 9:19 a.m. UTC
Fix the following message when libfribidi is enabled but not already
built:
Package fribidi was not found in the pkg-config search path.
Perhaps you should add the directory containing `fribidi.pc'
No package 'fribidi' found

Signed-off-by: Fabio Porcedda <fabio.porcedda@gmail.com>
---
 package/efl/libevas/libevas.mk | 7 +++++++
 1 file changed, 7 insertions(+)

Comments

Peter Korsgaard March 1, 2015, 9:02 p.m. UTC | #1
>>>>> "Fabio" == Fabio Porcedda <fabio.porcedda@gmail.com> writes:

 > Fix the following message when libfribidi is enabled but not already
 > built:
 > Package fribidi was not found in the pkg-config search path.
 > Perhaps you should add the directory containing `fribidi.pc'
 > No package 'fribidi' found

 > Signed-off-by: Fabio Porcedda <fabio.porcedda@gmail.com>

Committed, thanks.
diff mbox

Patch

diff --git a/package/efl/libevas/libevas.mk b/package/efl/libevas/libevas.mk
index 40a01e7..10c3bc3 100644
--- a/package/efl/libevas/libevas.mk
+++ b/package/efl/libevas/libevas.mk
@@ -225,6 +225,13 @@  else
 LIBEVAS_CONF_OPTS += --disable-fontconfig
 endif
 
+ifeq ($(BR2_PACKAGE_LIBFRIBIDI),y)
+LIBEVAS_CONF_OPTS += --enable-fribidi
+LIBEVAS_DEPENDENCIES += libfribidi
+else
+LIBEVAS_CONF_OPTS += --disable-fribidi
+endif
+
 # libevas installs the source code of examples on the target, which
 # are generally not useful.
 define LIBEVAS_REMOVE_EXAMPLES