diff mbox

[5/5] barebox: add option to specify config fragments

Message ID 1424003638-21689-5-git-send-email-bos@je-eigen-domein.nl
State Superseded
Headers show

Commit Message

Floris Bos Feb. 15, 2015, 12:33 p.m. UTC
Signed-off-by: Floris Bos <bos@je-eigen-domein.nl>
---
 boot/barebox/Config.in  | 6 ++++++
 boot/barebox/barebox.mk | 1 +
 2 files changed, 7 insertions(+)

Comments

Yann E. MORIN March 20, 2015, 11:23 p.m. UTC | #1
Floris, All,

On 2015-02-15 13:33 +0100, Floris Bos spake thusly:
> Signed-off-by: Floris Bos <bos@je-eigen-domein.nl>
> ---
>  boot/barebox/Config.in  | 6 ++++++
>  boot/barebox/barebox.mk | 1 +
>  2 files changed, 7 insertions(+)
> 
> diff --git a/boot/barebox/Config.in b/boot/barebox/Config.in
> index 48431bd..64e3196 100644
> --- a/boot/barebox/Config.in
> +++ b/boot/barebox/Config.in
> @@ -91,6 +91,12 @@ config BR2_TARGET_BAREBOX_CUSTOM_CONFIG_FILE
>  	help
>  	  Path to the barebox configuration file
>  
> +config BR2_TARGET_BAREBOX_CONFIG_FRAGMENT_FILES
> +	string "Additional configuration fragment files"
> +	help
> +	  A space-seperated list of configuration fragment files,

separated   (lotta copy-paste, eh?)

Otherwise, OK:

Reviewed-by: "Yann E. MORIN" <yann.morin.1998@free.fr>

Regards,
Yann E. MORIN.

> +	  that will be merged to the main Barebox configuration file.
> +
>  config BR2_TARGET_BAREBOX_BAREBOXENV
>  	bool "bareboxenv tool in target"
>  	help
> diff --git a/boot/barebox/barebox.mk b/boot/barebox/barebox.mk
> index b829ae7..41f487b 100644
> --- a/boot/barebox/barebox.mk
> +++ b/boot/barebox/barebox.mk
> @@ -59,6 +59,7 @@ BAREBOX_SOURCE_CONFIG = $(call qstrip,$(BR2_TARGET_BAREBOX_CUSTOM_CONFIG_FILE))
>  endif
>  
>  BAREBOX_KCONFIG_FILE = $(BAREBOX_SOURCE_CONFIG)
> +BAREBOX_KCONFIG_FRAGMENT_FILES = $(call qstrip,$(BR2_TARGET_BAREBOX_CONFIG_FRAGMENT_FILES))
>  BAREBOX_KCONFIG_EDITORS = menuconfig xconfig gconfig nconfig
>  BAREBOX_KCONFIG_OPTS = $(BAREBOX_MAKE_FLAGS)
>  
> -- 
> 1.9.1
> 
> _______________________________________________
> buildroot mailing list
> buildroot@busybox.net
> http://lists.busybox.net/mailman/listinfo/buildroot
diff mbox

Patch

diff --git a/boot/barebox/Config.in b/boot/barebox/Config.in
index 48431bd..64e3196 100644
--- a/boot/barebox/Config.in
+++ b/boot/barebox/Config.in
@@ -91,6 +91,12 @@  config BR2_TARGET_BAREBOX_CUSTOM_CONFIG_FILE
 	help
 	  Path to the barebox configuration file
 
+config BR2_TARGET_BAREBOX_CONFIG_FRAGMENT_FILES
+	string "Additional configuration fragment files"
+	help
+	  A space-seperated list of configuration fragment files,
+	  that will be merged to the main Barebox configuration file.
+
 config BR2_TARGET_BAREBOX_BAREBOXENV
 	bool "bareboxenv tool in target"
 	help
diff --git a/boot/barebox/barebox.mk b/boot/barebox/barebox.mk
index b829ae7..41f487b 100644
--- a/boot/barebox/barebox.mk
+++ b/boot/barebox/barebox.mk
@@ -59,6 +59,7 @@  BAREBOX_SOURCE_CONFIG = $(call qstrip,$(BR2_TARGET_BAREBOX_CUSTOM_CONFIG_FILE))
 endif
 
 BAREBOX_KCONFIG_FILE = $(BAREBOX_SOURCE_CONFIG)
+BAREBOX_KCONFIG_FRAGMENT_FILES = $(call qstrip,$(BR2_TARGET_BAREBOX_CONFIG_FRAGMENT_FILES))
 BAREBOX_KCONFIG_EDITORS = menuconfig xconfig gconfig nconfig
 BAREBOX_KCONFIG_OPTS = $(BAREBOX_MAKE_FLAGS)