diff mbox

[2/2] automake: use whenever possible the ACLOCAL_DIR variable

Message ID 1422809500-23948-2-git-send-email-fabio.porcedda@gmail.com
State Accepted
Commit 65b3cda915f04d1c0a108c4163ea72e459f20652
Headers show

Commit Message

Fabio Porcedda Feb. 1, 2015, 4:51 p.m. UTC
Use the ACLOCAL_DIR in the GTK_DOC_M4_INSTALL hook.

Move the ACLOCAL_DIR definition at the beginning so the definition is
ahead the utilization.

Signed-off-by: Fabio Porcedda <fabio.porcedda@gmail.com>
---
 package/automake/automake.mk | 6 ++++--
 1 file changed, 4 insertions(+), 2 deletions(-)

Comments

Romain Naour Feb. 1, 2015, 9:52 p.m. UTC | #1
Hi Fabio,

Le 01/02/2015 17:51, Fabio Porcedda a écrit :
> Use the ACLOCAL_DIR in the GTK_DOC_M4_INSTALL hook.
> 
> Move the ACLOCAL_DIR definition at the beginning so the definition is
> ahead the utilization.
> 
> Signed-off-by: Fabio Porcedda <fabio.porcedda@gmail.com>
> ---
>  package/automake/automake.mk | 6 ++++--
>  1 file changed, 4 insertions(+), 2 deletions(-)
> 
> diff --git a/package/automake/automake.mk b/package/automake/automake.mk
> index 5021b49..264cbad 100644
> --- a/package/automake/automake.mk
> +++ b/package/automake/automake.mk
> @@ -12,8 +12,11 @@ AUTOMAKE_LICENSE_FILES = COPYING
>  
>  HOST_AUTOMAKE_DEPENDENCIES = host-autoconf
>  
> +ACLOCAL_DIR = $(HOST_DIR)/usr/share/aclocal
> +
>  define GTK_DOC_M4_INSTALL
> -	$(INSTALL) -D -m 0644 package/automake/gtk-doc.m4 $(HOST_DIR)/usr/share/aclocal/gtk-doc.m4
> +	$(INSTALL) -D -m 0644 package/automake/gtk-doc.m4 \
> +		$(ACLOCAL_DIR)/gtk-doc.m4
>  endef
>  
>  # ensure staging aclocal dir exists
> @@ -28,5 +31,4 @@ $(eval $(host-autotools-package))
>  
>  # variables used by other packages
>  AUTOMAKE = $(HOST_DIR)/usr/bin/automake
> -ACLOCAL_DIR = $(HOST_DIR)/usr/share/aclocal
>  ACLOCAL = $(HOST_DIR)/usr/bin/aclocal -I $(ACLOCAL_DIR)
> 

Reviewed-by: Romain Naour <romain.naour@openwide.fr>

Best regards,
Romain Naour
Peter Korsgaard Feb. 2, 2015, 11:02 p.m. UTC | #2
>>>>> "Fabio" == Fabio Porcedda <fabio.porcedda@gmail.com> writes:

 > Use the ACLOCAL_DIR in the GTK_DOC_M4_INSTALL hook.
 > Move the ACLOCAL_DIR definition at the beginning so the definition is
 > ahead the utilization.

 > Signed-off-by: Fabio Porcedda <fabio.porcedda@gmail.com>

Committed, thanks.
Fabio Porcedda Feb. 8, 2015, 10:48 a.m. UTC | #3
On Tue, Feb 3, 2015 at 12:02 AM, Peter Korsgaard <peter@korsgaard.com> wrote:
>>>>>> "Fabio" == Fabio Porcedda <fabio.porcedda@gmail.com> writes:
>
>  > Use the ACLOCAL_DIR in the GTK_DOC_M4_INSTALL hook.
>  > Move the ACLOCAL_DIR definition at the beginning so the definition is
>  > ahead the utilization.
>
>  > Signed-off-by: Fabio Porcedda <fabio.porcedda@gmail.com>
>
> Committed, thanks.

I've sent an updated version of this patch:
http://patchwork.ozlabs.org/patch/437690/

BR
diff mbox

Patch

diff --git a/package/automake/automake.mk b/package/automake/automake.mk
index 5021b49..264cbad 100644
--- a/package/automake/automake.mk
+++ b/package/automake/automake.mk
@@ -12,8 +12,11 @@  AUTOMAKE_LICENSE_FILES = COPYING
 
 HOST_AUTOMAKE_DEPENDENCIES = host-autoconf
 
+ACLOCAL_DIR = $(HOST_DIR)/usr/share/aclocal
+
 define GTK_DOC_M4_INSTALL
-	$(INSTALL) -D -m 0644 package/automake/gtk-doc.m4 $(HOST_DIR)/usr/share/aclocal/gtk-doc.m4
+	$(INSTALL) -D -m 0644 package/automake/gtk-doc.m4 \
+		$(ACLOCAL_DIR)/gtk-doc.m4
 endef
 
 # ensure staging aclocal dir exists
@@ -28,5 +31,4 @@  $(eval $(host-autotools-package))
 
 # variables used by other packages
 AUTOMAKE = $(HOST_DIR)/usr/bin/automake
-ACLOCAL_DIR = $(HOST_DIR)/usr/share/aclocal
 ACLOCAL = $(HOST_DIR)/usr/bin/aclocal -I $(ACLOCAL_DIR)