diff mbox

webkit: Add --enable-dependency-tracking to the configure options

Message ID 1415297036-21850-1-git-send-email-Vincent.Riera@imgtec.com
State Accepted
Commit 8918cc50cb19af1e5cd51f2aa933ac755439d576
Headers show

Commit Message

Vicente Olivert Riera Nov. 6, 2014, 6:03 p.m. UTC
--disable-dependency-tracking was added globally to
package/pkg-autotools.mk by this commit:

http://git.buildroot.net/buildroot/commit/?id=3e37b0fc6cbbe2245e39fedb247a381fb4e0d992

This causes a failure in webkit because some source files are generated
after the Makefile is created. To fix this, we add
--enable-dependency-tracking to the configure options.

Fixes:
  http://autobuild.buildroot.net/results/5beea967b02df202bca1d42afd6fa8c2c13383d5/

Cc: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Vicente Olivert Riera <Vincent.Riera@imgtec.com>
---
 package/webkit/webkit.mk |    1 +
 1 files changed, 1 insertions(+), 0 deletions(-)

Comments

Thomas Petazzoni Nov. 6, 2014, 6:09 p.m. UTC | #1
Dear Vicente Olivert Riera,

On Thu, 6 Nov 2014 18:03:56 +0000, Vicente Olivert Riera wrote:
> --disable-dependency-tracking was added globally to
> package/pkg-autotools.mk by this commit:
> 
> http://git.buildroot.net/buildroot/commit/?id=3e37b0fc6cbbe2245e39fedb247a381fb4e0d992
> 
> This causes a failure in webkit because some source files are generated
> after the Makefile is created. To fix this, we add
> --enable-dependency-tracking to the configure options.
> 
> Fixes:
>   http://autobuild.buildroot.net/results/5beea967b02df202bca1d42afd6fa8c2c13383d5/

Aaah, that's what causing the build failure of webkit. I believe it's
wrong for webkit to do that, because dependency tracking should only be
needed for the developers of the package, and not needed for a normal
build. But since we're anyway going to bump webkit at some point thanks
to the work of Eric Le Bihan, I don't think we want to debug this
webkit version.

Therefore:

Acked-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>

And thanks a lot for the investigation!

Thomas
Peter Korsgaard Nov. 6, 2014, 10:04 p.m. UTC | #2
>>>>> "Vicente" == Vicente Olivert Riera <Vincent.Riera@imgtec.com> writes:

 > --disable-dependency-tracking was added globally to
 > package/pkg-autotools.mk by this commit:

 > http://git.buildroot.net/buildroot/commit/?id=3e37b0fc6cbbe2245e39fedb247a381fb4e0d992

 > This causes a failure in webkit because some source files are generated
 > after the Makefile is created. To fix this, we add
 > --enable-dependency-tracking to the configure options.

 > Fixes:
 >   http://autobuild.buildroot.net/results/5beea967b02df202bca1d42afd6fa8c2c13383d5/

 > Cc: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
 > Signed-off-by: Vicente Olivert Riera <Vincent.Riera@imgtec.com>

Committed, thanks.
diff mbox

Patch

diff --git a/package/webkit/webkit.mk b/package/webkit/webkit.mk
index fae2e7e..98da1d6 100644
--- a/package/webkit/webkit.mk
+++ b/package/webkit/webkit.mk
@@ -40,6 +40,7 @@  WEBKIT_CONF_ENV = ac_cv_path_icu_config=$(STAGING_DIR)/usr/bin/icu-config \
 	AR_FLAGS="cru"
 
 WEBKIT_CONF_OPTS += \
+	--enable-dependency-tracking \
 	--with-gtk=2.0 \
 	--disable-geolocation \
 	--disable-webkit2 \