diff mbox

[2/2] faifa: force GIT_REV to a correct value

Message ID 1402438557-29335-2-git-send-email-maxime.hadjinlian@gmail.com
State Accepted
Commit 04c32c30a1d39cc141484d6ebcab1f5f5e1dda2e
Headers show

Commit Message

Maxime Hadjinlian June 10, 2014, 10:15 p.m. UTC
This variable is looked up by the Makefile throught a git command line
invocation.
Since we don't keep the '.git' folder in the packages when we clone
them, the command line fail to find anything.

Even worse, it can keep going up the tree until it finds buildroot's
'.git' directory.

Signed-off-by: Maxime Hadjinlian <maxime.hadjinlian@gmail.com>
---
 package/faifa/faifa.mk | 2 ++
 1 file changed, 2 insertions(+)
diff mbox

Patch

diff --git a/package/faifa/faifa.mk b/package/faifa/faifa.mk
index 8f5d258..c83b02a 100644
--- a/package/faifa/faifa.mk
+++ b/package/faifa/faifa.mk
@@ -11,6 +11,8 @@  FAIFA_DEPENDENCIES = libpcap host-autoconf
 FAIFA_LICENSE = GPLv2+
 FAIFA_LICENSE_FILES = COPYING
 
+FAIFA_MAKE_OPT += GIT_REV=$(FAIFA_VERSION)
+
 # This package uses autoconf, but not automake, so we need to call
 # their special autogen.sh script, and have custom target and staging
 # installation commands.