diff mbox

[3/5] libao: Remove OSS plugin when ALSA is enabled

Message ID 1396979109-10691-3-git-send-email-paul@crapouillou.net
State Accepted
Commit a889c72cc833d0f9042a3fa74c14f488d665ce5c
Headers show

Commit Message

Paul Cercueil April 8, 2014, 5:45 p.m. UTC
From: Maarten ter Huurne <maarten@treewalker.org>

At runtime, libao will load all plugins, even ones that will never be used.
Since libao will prefer ALSA over OSS by default anyway, it is pretty safe
to exclude the OSS plugin.

There is no configure option for disabling the OSS plugin, so we remove
the shared object in a post-install hook.

Signed-Off-By: Maarten ter Huurne <maarten@treewalker.org>
---
 package/libao/libao.mk | 8 +++++++-
 1 file changed, 7 insertions(+), 1 deletion(-)

Comments

Peter Korsgaard May 3, 2014, 8:27 p.m. UTC | #1
>>>>> "Paul" == Paul Cercueil <paul@crapouillou.net> writes:

 > From: Maarten ter Huurne <maarten@treewalker.org>
 > At runtime, libao will load all plugins, even ones that will never be used.
 > Since libao will prefer ALSA over OSS by default anyway, it is pretty safe
 > to exclude the OSS plugin.

 > There is no configure option for disabling the OSS plugin, so we remove
 > the shared object in a post-install hook.

 > Signed-Off-By: Maarten ter Huurne <maarten@treewalker.org>

Committed with a note explaining why we now pass --disable-broken-oss,
thanks.
diff mbox

Patch

diff --git a/package/libao/libao.mk b/package/libao/libao.mk
index 8e9ee35..3f7d166 100644
--- a/package/libao/libao.mk
+++ b/package/libao/libao.mk
@@ -11,11 +11,17 @@  LIBAO_INSTALL_STAGING = YES
 LIBAO_LICENSE = GPLv2+
 LIBAO_LICENSE_FILES = COPYING
 LIBAO_CONF_OPT = --disable-esd --disable-wmm --disable-arts \
-			--disable-nas --disable-pulse
+			--disable-nas --disable-pulse --disable-broken-oss
 
 ifeq ($(BR2_PACKAGE_ALSA_LIB),y)
 LIBAO_DEPENDENCIES += alsa-lib
 LIBAO_CONF_OPT += --enable-alsa --enable-alsa-mmap
+
+# Remove the OSS plugin if ALSA is enabled, as libao will prefer ALSA anyway
+define LIBAO_REMOVE_OSS_PLUGIN
+	rm -f $(TARGET_DIR)/usr/lib/ao/plugins-4/liboss.so
+endef
+LIBAO_POST_INSTALL_TARGET_HOOKS += LIBAO_REMOVE_OSS_PLUGIN
 else
 LIBAO_CONF_OPT += --disable-alsa
 endif