diff mbox

[5/6] infra: add to luarocks support for top-level parallel make

Message ID 1394540278-28740-6-git-send-email-fabio.porcedda@gmail.com
State Superseded
Headers show

Commit Message

Fabio Porcedda March 11, 2014, 12:17 p.m. UTC
The host-luarock dependency is not always satisfied for the extract
phase because the %-extract target is not anymore in the dependency
chain.
To be sure that the dependency is satfied add the dependency to the
stamp file $(%_TARGET_EXTRACT) instead of the %-extract target.

Signed-off-by: Fabio Porcedda <fabio.porcedda@gmail.com>
Cc: Francois Perrad <fperrad@gmail.com>
---
 package/pkg-luarocks.mk | 8 ++++----
 1 file changed, 4 insertions(+), 4 deletions(-)

Comments

Francois Perrad March 11, 2014, 7:42 p.m. UTC | #1
2014-03-11 13:17 GMT+01:00 Fabio Porcedda <fabio.porcedda@gmail.com>:
> The host-luarock dependency is not always satisfied for the extract
> phase because the %-extract target is not anymore in the dependency
> chain.
> To be sure that the dependency is satfied add the dependency to the

typo: satisfied

> stamp file $(%_TARGET_EXTRACT) instead of the %-extract target.
>
> Signed-off-by: Fabio Porcedda <fabio.porcedda@gmail.com>
> Cc: Francois Perrad <fperrad@gmail.com>
> ---
>  package/pkg-luarocks.mk | 8 ++++----
>  1 file changed, 4 insertions(+), 4 deletions(-)
>
> diff --git a/package/pkg-luarocks.mk b/package/pkg-luarocks.mk
> index bdda022..7010381 100644
> --- a/package/pkg-luarocks.mk
> +++ b/package/pkg-luarocks.mk
> @@ -43,10 +43,6 @@ $(2)_SITE            ?= $(call qstrip,$(BR2_LUAROCKS_MIRROR))
>  # a target package, and can just add the required dependencies
>  $(2)_DEPENDENCIES      += host-luarocks luainterpreter
>
> -# $(2)_DEPENDENCIES are handled for configure step (too late)
> -# but host-luarocks is required to do the extract
> -$(1)-extract: host-luarocks
> -
>  #
>  # Extract step
>  #
> @@ -71,6 +67,10 @@ endif
>  # make targets
>  $(call inner-generic-package,$(1),$(2),$(3),$(4))
>
> +# $(2)_DEPENDENCIES are handled for configure step (too late)
> +# but host-luarocks is required to do the extract
> +$$($(2)_TARGET_EXTRACT): | host-luarocks
> +
>  endef
>
>  ################################################################################
> --
> 1.8.3.2
>
> _______________________________________________
> buildroot mailing list
> buildroot@busybox.net
> http://lists.busybox.net/mailman/listinfo/buildroot
Fabio Porcedda April 1, 2014, 8:39 a.m. UTC | #2
On Tue, Mar 11, 2014 at 8:42 PM, François Perrad
<francois.perrad@gadz.org> wrote:
> 2014-03-11 13:17 GMT+01:00 Fabio Porcedda <fabio.porcedda@gmail.com>:
>> The host-luarock dependency is not always satisfied for the extract
>> phase because the %-extract target is not anymore in the dependency
>> chain.
>> To be sure that the dependency is satfied add the dependency to the
>
> typo: satisfied

I've corrected the type, thanks.

Regards
diff mbox

Patch

diff --git a/package/pkg-luarocks.mk b/package/pkg-luarocks.mk
index bdda022..7010381 100644
--- a/package/pkg-luarocks.mk
+++ b/package/pkg-luarocks.mk
@@ -43,10 +43,6 @@  $(2)_SITE		?= $(call qstrip,$(BR2_LUAROCKS_MIRROR))
 # a target package, and can just add the required dependencies
 $(2)_DEPENDENCIES	+= host-luarocks luainterpreter
 
-# $(2)_DEPENDENCIES are handled for configure step (too late)
-# but host-luarocks is required to do the extract
-$(1)-extract: host-luarocks
-
 #
 # Extract step
 #
@@ -71,6 +67,10 @@  endif
 # make targets
 $(call inner-generic-package,$(1),$(2),$(3),$(4))
 
+# $(2)_DEPENDENCIES are handled for configure step (too late)
+# but host-luarocks is required to do the extract
+$$($(2)_TARGET_EXTRACT): | host-luarocks
+
 endef
 
 ################################################################################