diff mbox

ti-uim: Add new package

Message ID 1386502217-2761-1-git-send-email-alexandre.belloni@free-electrons.com
State Accepted
Headers show

Commit Message

Alexandre Belloni Dec. 8, 2013, 11:30 a.m. UTC
Signed-off-by: Alexandre Belloni <alexandre.belloni@free-electrons.com>
---
 package/Config.in        |  1 +
 package/ti-uim/Config.in |  8 ++++++++
 package/ti-uim/ti-uim.mk | 21 +++++++++++++++++++++
 3 files changed, 30 insertions(+)
 create mode 100644 package/ti-uim/Config.in
 create mode 100644 package/ti-uim/ti-uim.mk

Comments

Yann E. MORIN Dec. 8, 2013, 11:55 a.m. UTC | #1
Alexandre, All,

On 2013-12-08 12:30 +0100, Alexandre Belloni spake thusly:
> Signed-off-by: Alexandre Belloni <alexandre.belloni@free-electrons.com>
> ---
>  package/Config.in        |  1 +
>  package/ti-uim/Config.in |  8 ++++++++
>  package/ti-uim/ti-uim.mk | 21 +++++++++++++++++++++
>  3 files changed, 30 insertions(+)
>  create mode 100644 package/ti-uim/Config.in
>  create mode 100644 package/ti-uim/ti-uim.mk
[--SNIP--]
> diff --git a/package/ti-uim/ti-uim.mk b/package/ti-uim/ti-uim.mk
> new file mode 100644
> index 000000000000..86e8b882a8b2
> --- /dev/null
> +++ b/package/ti-uim/ti-uim.mk
> @@ -0,0 +1,21 @@
> +#############################################################
> +#
> +# ti-uim
> +#
> +#############################################################
> +
> +TI_UIM_VERSION = c738944
> +TI_UIM_SITE = git://gitorious.org/uim/uim.git
> +TI_UIM_LICENSE = GPLv2+
> +TI_UIM_LICENSE_FILES = uim.c

I don't think we can consider the source file to be the license file.
We should just consider that there is no license file in this package.

Anyway, 'make legal-info' will copy the source file, so the licensing
information in that file will be available, no need to duplicate it.

> +define TI_UIM_BUILD_CMDS
> +	$(MAKE) -C $(@D) $(TARGET_CONFIGURE_OPTS)
> +endef
> +
> +define TI_UIM_INSTALL_TARGET_CMDS
> +	$(INSTALL) -m 0755 -D $(@D)/uim \
> +		$(TARGET_DIR)/usr/sbin/uim
> +endef
> +
> +$(eval $(generic-package))

Regards,
Yann E. MORIN.
Peter Korsgaard Dec. 16, 2013, 9:52 p.m. UTC | #2
>>>>> "Alexandre" == Alexandre Belloni <alexandre.belloni@free-electrons.com> writes:

 > Signed-off-by: Alexandre Belloni <alexandre.belloni@free-electrons.com>
 > ---
 >  package/Config.in        |  1 +
 >  package/ti-uim/Config.in |  8 ++++++++
 >  package/ti-uim/ti-uim.mk | 21 +++++++++++++++++++++
 >  3 files changed, 30 insertions(+)
 >  create mode 100644 package/ti-uim/Config.in
 >  create mode 100644 package/ti-uim/ti-uim.mk

 > diff --git a/package/Config.in b/package/Config.in
 > index a7ab4ea9d535..8947fc1dc686 100644
 > --- a/package/Config.in
 > +++ b/package/Config.in
 > @@ -329,6 +329,7 @@ source "package/sunxi-mali/Config.in"
 >  source "package/sunxi-mali-prop/Config.in"
 >  source "package/sysstat/Config.in"
 >  source "package/ti-gfx/Config.in"
 > +source "package/ti-uim/Config.in"
 >  source "package/ti-utils/Config.in"
 >  source "package/uboot-tools/Config.in"
 >  source "package/udev/Config.in"
 > diff --git a/package/ti-uim/Config.in b/package/ti-uim/Config.in
 > new file mode 100644
 > index 000000000000..0e2183d0cbc8
 > --- /dev/null
 > +++ b/package/ti-uim/Config.in
 > @@ -0,0 +1,8 @@
 > +config BR2_PACKAGE_TI_UIM
 > +	bool "ti-uim"
 > +	help
 > +	  User Mode Initialization Manager for TI wl12xx connectivity chip shared
 > +	  transport drivers. This daemon is needed to get the btwilink driver to
 > +	  work.
 > +

Help text should be wrapped so it displays in menuconfig in 80 cols
without scrolling.

 > +	  http://omappedia.org/wiki/Device_Driver_Interface_of_WiLink_Solution
 > diff --git a/package/ti-uim/ti-uim.mk b/package/ti-uim/ti-uim.mk
 > new file mode 100644
 > index 000000000000..86e8b882a8b2
 > --- /dev/null
 > +++ b/package/ti-uim/ti-uim.mk
 > @@ -0,0 +1,21 @@
 > +#############################################################
 > +#
 > +# ti-uim
 > +#
 > +#############################################################

Somebody once went through the tree changing the file headers to all use
80 chars, so we should keep it like that ;)

Committed with those fixes, thanks.
Peter Korsgaard Dec. 16, 2013, 9:53 p.m. UTC | #3
>>>>> "Alexandre" == Alexandre Belloni <alexandre.belloni@free-electrons.com> writes:

 > +#############################################################
 > +
 > +TI_UIM_VERSION = c738944

Ups, forgot to mention that the full 40 char git hash should be used.
diff mbox

Patch

diff --git a/package/Config.in b/package/Config.in
index a7ab4ea9d535..8947fc1dc686 100644
--- a/package/Config.in
+++ b/package/Config.in
@@ -329,6 +329,7 @@  source "package/sunxi-mali/Config.in"
 source "package/sunxi-mali-prop/Config.in"
 source "package/sysstat/Config.in"
 source "package/ti-gfx/Config.in"
+source "package/ti-uim/Config.in"
 source "package/ti-utils/Config.in"
 source "package/uboot-tools/Config.in"
 source "package/udev/Config.in"
diff --git a/package/ti-uim/Config.in b/package/ti-uim/Config.in
new file mode 100644
index 000000000000..0e2183d0cbc8
--- /dev/null
+++ b/package/ti-uim/Config.in
@@ -0,0 +1,8 @@ 
+config BR2_PACKAGE_TI_UIM
+	bool "ti-uim"
+	help
+	  User Mode Initialization Manager for TI wl12xx connectivity chip shared
+	  transport drivers. This daemon is needed to get the btwilink driver to
+	  work.
+
+	  http://omappedia.org/wiki/Device_Driver_Interface_of_WiLink_Solution
diff --git a/package/ti-uim/ti-uim.mk b/package/ti-uim/ti-uim.mk
new file mode 100644
index 000000000000..86e8b882a8b2
--- /dev/null
+++ b/package/ti-uim/ti-uim.mk
@@ -0,0 +1,21 @@ 
+#############################################################
+#
+# ti-uim
+#
+#############################################################
+
+TI_UIM_VERSION = c738944
+TI_UIM_SITE = git://gitorious.org/uim/uim.git
+TI_UIM_LICENSE = GPLv2+
+TI_UIM_LICENSE_FILES = uim.c
+
+define TI_UIM_BUILD_CMDS
+	$(MAKE) -C $(@D) $(TARGET_CONFIGURE_OPTS)
+endef
+
+define TI_UIM_INSTALL_TARGET_CMDS
+	$(INSTALL) -m 0755 -D $(@D)/uim \
+		$(TARGET_DIR)/usr/sbin/uim
+endef
+
+$(eval $(generic-package))