@@ -461,6 +461,7 @@ source "package/libesmtp/Config.in"
source "package/libeXosip2/Config.in"
source "package/libfcgi/Config.in"
source "package/libidn/Config.in"
+source "package/libiscsi/Config.in"
source "package/liboauth/Config.in"
source "package/libmicrohttpd/Config.in"
source "package/neon/Config.in"
new file mode 100644
@@ -0,0 +1,12 @@
+config BR2_PACKAGE_LIBISCSI
+ bool "libiscsi"
+ select BR2_PACKAGE_POPT
+ help
+ Libiscsi is a client-side library to implement the iSCSI protocol
+ that can be used to access resource of an iSCSI Target.
+
+ The library is fully async with regards to iscsi commands and scsi
+ tasks, but a sync layer is also provided for ease of use for simpler
+ applications.
+
+ https://github.com/sahlberg/libiscsi (no proper homepage)
new file mode 100644
@@ -0,0 +1,15 @@
+#############################################################
+#
+# libiscsi
+#
+#############################################################
+
+LIBISCSI_VERSION = 1.6.0
+LIBISCSI_SOURCE = libiscsi-$(LIBISCSI_VERSION).tar.gz
+LIBISCSI_SITE = https://github.com/downloads/sahlberg/libiscsi
+LIBISCSI_LICENSE = GPLv2+ LGPLv2.1+
+LIBISCSI_LICENSE_FILES = COPYING LICENCE-GPL-2.txt LICENCE-LGPL-2.1.txt
+LIBISCSI_INSTALL_STAGING = YES
+LIBISCSI_DEPENDENCIES = popt
+
+$(eval $(autotools-package))
Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Cc: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> --- package/Config.in | 1 + package/libiscsi/Config.in | 12 ++++++++++++ package/libiscsi/libiscsi.mk | 15 +++++++++++++++ 3 files changed, 28 insertions(+), 0 deletions(-) create mode 100644 package/libiscsi/Config.in create mode 100644 package/libiscsi/libiscsi.mk