@@ -256,6 +256,13 @@ comment "Alsa sound static link works only if BR2_PREFER_STATIC is set"
comment "Misc. features"
+config BR2_PACKAGE_QEMU_FDT
+ bool "Enable FDT"
+ select BR2_PACKAGE_DTC
+ help
+ Say 'y' here to have QEMU capable of constructing Device Trees,
+ and passing them to the VMs.
+
config BR2_PACKAGE_QEMU_UUID
bool "Enable VMs UUID"
depends on BR2_PACKAGE_UTIL_LINUX_LIBUUID
@@ -228,6 +228,13 @@ ifeq ($(BR2_PACKAGE_QEMU_MIXEMU),y)
QEMU_OPTS += --enable-mixemu
endif
+ifeq ($(BR2_PACKAGE_QEMU_FDT),y)
+QEMU_OPTS += --enable-fdt
+QEMU_DEPENDENCIES += dtc
+else
+QEMU_OPTS += --disable-fdt
+endif
+
ifeq ($(BR2_PACKAGE_QEMU_UUID),y)
QEMU_OPTS += --enable-uuid
QEMU_DEPENDENCIES += util-linux
@@ -348,7 +355,6 @@ define QEMU_CONFIGURE_CMDS
--disable-slirp \
--disable-vnc-sasl \
--disable-brlapi \
- --disable-fdt \
--disable-guest-base \
--disable-rbd \
--disable-smartcard \
FDT is the Flat Device Tree, and allows QEMU to pass DTs to the VMs. Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr> --- package/qemu/Config.in | 7 +++++++ package/qemu/qemu.mk | 8 +++++++- 2 files changed, 14 insertions(+), 1 deletions(-)