@@ -266,6 +266,13 @@ config BR2_PACKAGE_QEMU_ATTR
Say 'y' here to have QEMU support attributes (attr) and eXtended
attibutes (xattr).
+config BR2_PACKAGE_QEMU_SECCOMP
+ bool "Enable seccomp filter"
+ select BR2_PACKAGE_LIBSECCOMP
+ help
+ Say 'y' here to have QEMU to use the Linux kernel's seccomp filter,
+ to more tightly confine the VMs.
+
config BR2_PACKAGE_QEMU_BLOBS
bool "Install binary blobs"
default y
@@ -251,6 +251,12 @@ else
QEMU_OPTS += --disable-attr
endif
+ifeq ($(BR2_PACKAGE_QEMU_SECCOMP),y)
+QEMU_OPTS += --enable-seccomp
+else
+QEMU_OPTS += --disable-seccomp
+endif
+
ifeq ($(BR2_PACKAGE_QEMU_BLOBS),)
QEMU_OPTS += --disable-blobs
endif
@@ -338,7 +344,6 @@ define QEMU_CONFIGURE_CMDS
--disable-rbd \
--disable-smartcard \
--disable-strip \
- --disable-seccomp \
--disable-sparse \
$(QEMU_OPTS) \
)
Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr> --- package/qemu/Config.in | 7 +++++++ package/qemu/qemu.mk | 7 ++++++- 2 files changed, 13 insertions(+), 1 deletions(-)