@@ -126,6 +126,16 @@ config BR2_PACKAGE_QEMU_CURSES
frontend (although you can still use the SDL or VNC frontends to
display the graphical output).
+config BR2_PACKAGE_QEMU_SPICE
+ bool "Enable Spice frontend"
+ depends on BR2_PACKAGE_SPICE
+ help
+ Say 'y' here to have QEMU support Spice as a (VNC-like) frontend.
+
+if !BR2_PACKAGE_SPICE
+comment "Spice support requires spice-server"
+endif
+
comment "Block backends"
config BR2_PACKAGE_QEMU_VIRTFS
@@ -156,6 +156,13 @@ else
QEMU_OPTS += --disable-curses
endif
+ifeq ($(BR2_PACKAGE_QEMU_SPICE),y)
+QEMU_OPTS += --enable-spice
+QEMU_DEPENDENCIES += spice
+else
+QEMU_OPTS += --disable-spice
+endif
+
ifeq ($(BR2_PACKAGE_QEMU_VIRTFS),y)
QEMU_OPTS += --enable-virtfs
else
@@ -313,7 +320,6 @@ define QEMU_CONFIGURE_CMDS
--disable-fdt \
--disable-guest-base \
--disable-docs \
- --disable-spice \
--disable-rbd \
--disable-smartcard \
--disable-strip \
Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr> --- package/qemu/Config.in | 10 ++++++++++ package/qemu/qemu.mk | 8 +++++++- 2 files changed, 17 insertions(+), 1 deletions(-)