@@ -172,6 +172,13 @@ config BR2_PACKAGE_QEMU_BLUEZ
comment "BlueZ connectivity depends on bluez-utils"
depends on !BR2_PACKAGE_BLUEZ_UTILS
+config BR2_PACKAGE_QEMU_VDE
+ bool "Enable VDE"
+ select BR2_PACKAGE_VDE2
+ help
+ Say 'y' here to have QEMU connect to VDE (Virtual Distributed
+ Ethernet) switches.
+
comment "Misc. features"
config BR2_PACKAGE_QEMU_UUID
@@ -183,6 +183,13 @@ else
QEMU_OPTS += --disable-bluez
endif
+ifeq ($(BR2_PACKAGE_QEMU_VDE),y)
+QEMU_OPTS += --enable-vde
+QEMU_DEPENDENCIES += vde2
+else
+QEMU_OPTS += --disable-vde
+endif
+
ifeq ($(BR2_PACKAGE_QEMU_UUID),y)
QEMU_OPTS += --enable-uuid
QEMU_DEPENDENCIES += util-linux
@@ -291,7 +298,6 @@ define QEMU_CONFIGURE_CMDS
--disable-brlapi \
--disable-fdt \
--disable-guest-base \
- --disable-vde \
--disable-docs \
--disable-spice \
--disable-rbd \
Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr> --- package/qemu/Config.in | 7 +++++++ package/qemu/qemu.mk | 8 +++++++- 2 files changed, 14 insertions(+), 1 deletions(-)