@@ -131,6 +131,16 @@ config BR2_PACKAGE_QEMU_VIRTFS
file-system called 9p, and can be accelerated by using the 9p
virtio).
+config BR2_PACKAGE_QEMU_CURL
+ bool "Enable remote block-devices using cURL"
+ depends on !BR2_PREFER_STATIC_LIB
+ select BR2_PACKAGE_LIBCURL
+ help
+ Say 'y' to access remote block-devices using libcurl.
+
+comment "cURL support is not possible with static linking"
+ depends on BR2_PREFER_STATIC_LIB
+
comment "Misc. features"
config BR2_PACKAGE_QEMU_UUID
@@ -155,6 +155,13 @@ else
QEMU_OPTS += --disable-virtfs
endif
+ifeq ($(BR2_PACKAGE_QEMU_CURL),y)
+QEMU_OPTS += --enable-curl
+QEMU_DEPENDENCIES += libcurl
+else
+QEMU_OPTS += --disable-curl
+endif
+
ifeq ($(BR2_PACKAGE_QEMU_UUID),y)
QEMU_OPTS += --enable-uuid
QEMU_DEPENDENCIES += util-linux
@@ -262,7 +269,6 @@ define QEMU_CONFIGURE_CMDS
--disable-vnc-sasl \
--disable-brlapi \
--disable-curses \
- --disable-curl \
--disable-fdt \
--disable-bluez \
--disable-guest-base \
QEMU can use libcurl as a block backend, to access remote block devices. Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr> --- package/qemu/Config.in | 10 ++++++++++ package/qemu/qemu.mk | 8 +++++++- 2 files changed, 17 insertions(+), 1 deletions(-)