@@ -115,6 +115,22 @@ config BR2_PACKAGE_QEMU_SDL
Say 'y' to enable the SDL frontend, that is, a graphical window
presenting the VM's display.
+comment "Block backends"
+
+config BR2_PACKAGE_QEMU_VIRTFS
+ bool "Enable plan9 ressources using VirtFS"
+ select BR2_PACKAGE_QEMU_CAP
+ select BR2_PACKAGE_QEMU_ATTR
+ help
+ Say 'y' here if you want QEMU to provide a plan9 virtual "share"
+ accessible from the guest OS for relatively fast access to host
+ files.
+
+ This requires that the guest OS is capable of accessing plan9
+ ressources (typically, in Linux, this is done by a network
+ file-system called 9p, and can be accelerated by using the 9p
+ virtio).
+
comment "Misc. features"
config BR2_PACKAGE_QEMU_UUID
@@ -149,6 +149,12 @@ else
QEMU_OPTS += --disable-sdl
endif
+ifeq ($(BR2_PACKAGE_QEMU_VIRTFS),y)
+QEMU_OPTS += --enable-virtfs
+else
+QEMU_OPTS += --disable-virtfs
+endif
+
ifeq ($(BR2_PACKAGE_QEMU_UUID),y)
QEMU_OPTS += --enable-uuid
QEMU_DEPENDENCIES += util-linux
@@ -254,7 +260,6 @@ define QEMU_CONFIGURE_CMDS
--disable-xen \
--disable-slirp \
--disable-vnc-sasl \
- --disable-virtfs \
--disable-brlapi \
--disable-curses \
--disable-curl \
Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr> --- package/qemu/Config.in | 16 ++++++++++++++++ package/qemu/qemu.mk | 7 ++++++- 2 files changed, 22 insertions(+), 1 deletions(-)